summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-08-24 13:53:25 +0000
committerMamoru Komachi <usata@gentoo.org>2004-08-24 13:53:25 +0000
commita709872dbdc7cdbe83779d0960a55aabfea999f5 (patch)
treedeedda7315378d05d2bb0c97bb060314988e96c5 /app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild
parentFinal set of patches for known issues (Manifest recommit) (diff)
downloadgentoo-2-a709872dbdc7cdbe83779d0960a55aabfea999f5.tar.gz
gentoo-2-a709872dbdc7cdbe83779d0960a55aabfea999f5.tar.bz2
gentoo-2-a709872dbdc7cdbe83779d0960a55aabfea999f5.zip
Aborts if USE has async.
Diffstat (limited to 'app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild')
-rw-r--r--app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild b/app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild
index 1bf43e0365bd..ee182adcb97e 100644
--- a/app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild
+++ b/app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild,v 1.9 2004/06/26 11:53:44 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-w3m/emacs-w3m-1.3.6.ebuild,v 1.10 2004/08/24 13:53:25 usata Exp $
inherit elisp
@@ -17,6 +17,18 @@ KEYWORDS="x86 alpha ~ppc sparc"
DEPEND="virtual/emacs
virtual/w3m"
+pkg_setup() {
+ # use async doesn't ensure you built w3m with async flag,
+ # but it's safe to abort if you have it.
+ ewarn
+ ewarn "emacs-w3m hangs if you build w3m with async support."
+ ewarn "Please turn off async USE flag if you set it."
+ ewarn
+ if use async ; then
+ die "async USE flag detected. aborting."
+ fi
+}
+
src_compile() {
./configure --prefix=/usr \
--with-lispdir=${SITELISP}/${PN} \