summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-08-26 13:27:16 +0000
committerMamoru Komachi <usata@gentoo.org>2004-08-26 13:27:16 +0000
commit2c19f689543af0cd063fba658de87f2e655b9772 (patch)
tree46cb111bff1d61adabcf99a6d46e57e4f8df7d35 /app-emacs/ess/ess-5.2.2.ebuild
parentmarked galeon-1.3.17 stable on x86 (Manifest recommit) (diff)
downloadgentoo-2-2c19f689543af0cd063fba658de87f2e655b9772.tar.gz
gentoo-2-2c19f689543af0cd063fba658de87f2e655b9772.tar.bz2
gentoo-2-2c19f689543af0cd063fba658de87f2e655b9772.zip
Version bumped. SRC_URI and HOMEPAGE have bee changed. Marked previous version stable on x86 and added to ~alpha.
Diffstat (limited to 'app-emacs/ess/ess-5.2.2.ebuild')
-rw-r--r--app-emacs/ess/ess-5.2.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/ess/ess-5.2.2.ebuild b/app-emacs/ess/ess-5.2.2.ebuild
new file mode 100644
index 000000000000..f4928f7c8b12
--- /dev/null
+++ b/app-emacs/ess/ess-5.2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ess/ess-5.2.2.ebuild,v 1.1 2004/08/26 13:27:15 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://stat.ethz.ch/ESS/"
+SRC_URI="http://stat.ethz.ch/ESS/downloads/ess/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc"
+
+DEPEND="virtual/emacs
+ app-text/texi2html
+ sys-apps/sed
+ virtual/tetex"
+RDEPEND="virtual/emacs"
+
+SITEFILE=50ess-gentoo.el
+
+src_compile() {
+ einfo "Compiling lisp sources..."
+ pushd ${S}/lisp && make;
+ popd;
+ einfo "Making documentation..."
+ # The -glossary option doesn't work with Gentoo texi2html.
+ sed "s:-glossary::g" ${S}/doc/Makefile > ${T}/Makefile;
+ mv -f ${T}/Makefile ${S}/doc/Makefile;
+ pushd ${S}/doc && make;
+ popd;
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el lisp/*.elc;
+ elisp-site-file-install ${FILESDIR}/${SITEFILE};
+ doinfo ${S}/doc/*.info*;
+ dohtml ${S}/doc/*.html;
+ dodoc ${S}/doc/[N-Z]*;
+ dodoc ${S}/etc/{sas-keys.ps,ess-sas-sh-command,ess-s?.S}
+ insinto /usr/share/doc/${P}
+ doins ${S}/doc/ess-intro.pdf
+ insinto /usr/share/doc/${P}/examples
+ doins ${S}/etc/function-outline.S
+ cp -Rf ${S}/etc/other/S-spread ${D}/usr/share/doc/${P}/examples
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P} for the complete documentation."
+ einfo "Usage hints are in /usr/share/emacs/site-lisp/${PN}/ess-site.el."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}