summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-16 21:25:14 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-16 21:25:14 +0000
commit99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777 (patch)
tree023aad796fbdbf94aa22dbc894b406750a83a62c /app-emacs/http-emacs/http-emacs-1.1-r1.ebuild
parentAdded patch for webdav per security bug #196066. Removed past version, and va... (diff)
downloadgentoo-2-99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777.tar.gz
gentoo-2-99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777.tar.bz2
gentoo-2-99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777.zip
Also byte-compile the simple-wiki elisp files.
(Portage version: 2.1.3.13)
Diffstat (limited to 'app-emacs/http-emacs/http-emacs-1.1-r1.ebuild')
-rw-r--r--app-emacs/http-emacs/http-emacs-1.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild b/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild
new file mode 100644
index 000000000000..24979d67c425
--- /dev/null
+++ b/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild,v 1.1 2007/10/16 21:25:14 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Fetch, render and post html pages and edit wiki pages via Emacs."
+HOMEPAGE="http://emacswiki.org/cgi-bin/wiki.pl?SimpleWikiEditMode"
+SRC_URI="http://savannah.nongnu.org/download/http-emacs/http-emacs.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+DOCS="CONTRIBUTORS"
+
+SITEFILE=51${PN}-gentoo.el
+
+src_compile() {
+ elisp-comp *.el || die "elisp-comp failed"
+}