summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-06-01 06:11:37 +0000
committerUlrich Müller <ulm@gentoo.org>2010-06-01 06:11:37 +0000
commitd4d1b5cf4236d97aa1b01fd15ac46058099aba77 (patch)
tree69f0c456f1836452cbf84e072f9fa31603a1094f /app-emacs/mpg123-el
parentVersion bump. (diff)
downloadgentoo-2-d4d1b5cf4236d97aa1b01fd15ac46058099aba77.tar.gz
gentoo-2-d4d1b5cf4236d97aa1b01fd15ac46058099aba77.tar.bz2
gentoo-2-d4d1b5cf4236d97aa1b01fd15ac46058099aba77.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/mpg123-el')
-rw-r--r--app-emacs/mpg123-el/ChangeLog7
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.55.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/app-emacs/mpg123-el/ChangeLog b/app-emacs/mpg123-el/ChangeLog
index 4ea489bc5514..837177d58b18 100644
--- a/app-emacs/mpg123-el/ChangeLog
+++ b/app-emacs/mpg123-el/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/mpg123-el
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/ChangeLog,v 1.25 2010/01/13 20:39:44 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/ChangeLog,v 1.26 2010/06/01 06:11:37 ulm Exp $
+
+*mpg123-el-1.55 (01 Jun 2010)
+
+ 01 Jun 2010; Ulrich Mueller <ulm@gentoo.org> +mpg123-el-1.55.ebuild:
+ Version bump.
13 Jan 2010; Ulrich Mueller <ulm@gentoo.org> mpg123-el-1.52.ebuild:
Fix LICENSE, this is free software according to notice in mpg123.el.
diff --git a/app-emacs/mpg123-el/mpg123-el-1.55.ebuild b/app-emacs/mpg123-el/mpg123-el-1.55.ebuild
new file mode 100644
index 000000000000..2415445f769c
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.55.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.55.ebuild,v 1.1 2010/06/01 06:11:37 ulm Exp $
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis"
+
+DEPEND=""
+RDEPEND="media-sound/mpg123
+ media-sound/aumix
+ vorbis? ( media-sound/vorbis-tools )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ dobin tagput id3put || die
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}