summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-12-09 10:21:47 +0000
committerMamoru Komachi <usata@gentoo.org>2004-12-09 10:21:47 +0000
commitab84c6a8853df1b3bd7ec195ecf5090042a657ab (patch)
tree8abede7546b372e7421bbdbae9eab822764d3019 /app-emacs/riece/riece-1.0.6.ebuild
parent2.4.28 goes finally to stable x86. (Manifest recommit) (diff)
downloadgentoo-2-ab84c6a8853df1b3bd7ec195ecf5090042a657ab.tar.gz
gentoo-2-ab84c6a8853df1b3bd7ec195ecf5090042a657ab.tar.bz2
gentoo-2-ab84c6a8853df1b3bd7ec195ecf5090042a657ab.zip
Version bumped.
Diffstat (limited to 'app-emacs/riece/riece-1.0.6.ebuild')
-rw-r--r--app-emacs/riece/riece-1.0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-1.0.6.ebuild b/app-emacs/riece/riece-1.0.6.ebuild
new file mode 100644
index 000000000000..71753b2b7908
--- /dev/null
+++ b/app-emacs/riece/riece-1.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-1.0.6.ebuild,v 1.1 2004/12/09 10:21:47 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://wiliki.designflaw.org/riece.cgi"
+SRC_URI="http://wiliki.designflaw.org/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~amd64 ~ppc-macos"
+
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}