summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-13 04:23:49 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-13 04:23:49 +0000
commita321904e72ed817d42d0b547bd2c0996cc47777c (patch)
treee338c3fb71ddad6c55f057c670434abc59db6f48 /app-emacs/vm/vm-7.19-r1.ebuild
parentStable on SPARC. (diff)
downloadgentoo-2-a321904e72ed817d42d0b547bd2c0996cc47777c.tar.gz
gentoo-2-a321904e72ed817d42d0b547bd2c0996cc47777c.tar.bz2
gentoo-2-a321904e72ed817d42d0b547bd2c0996cc47777c.zip
MIME-type mailing list digest burst problem patch; Resolves Bug #108281.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'app-emacs/vm/vm-7.19-r1.ebuild')
-rw-r--r--app-emacs/vm/vm-7.19-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/vm/vm-7.19-r1.ebuild b/app-emacs/vm/vm-7.19-r1.ebuild
new file mode 100644
index 000000000000..c82d9cfc794f
--- /dev/null
+++ b/app-emacs/vm/vm-7.19-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-7.19-r1.ebuild,v 1.1 2006/08/13 04:23:49 mkennedy Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="An emacs major mode for reading and writing e-mail with support for GPG and MIME."
+HOMEPAGE="http://www.wonderworks.com/vm/"
+SRC_URI="ftp://ftp.uni-mainz.de/pub/software/gnu/${PN}/${P}.tar.gz
+ ftp://ftp.uu.net/networking/mail/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50vm-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/vm-direntry-fix-gentoo.patch
+ epatch ${FILESDIR}/vm-7.19-burst-digest.patch
+}
+
+src_compile() {
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/${SITELISP}/vm \
+ PIXMAPDIR=${D}/${SITELISP}/etc/${PN} \
+ all || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/${SITELISP}/vm \
+ PIXMAPDIR=${D}/${SITELISP}/etc/${PN} \
+ install || die
+ elisp-install ${PN} *.el
+ elisp-site-file-install ${FILESDIR}/50vm-gentoo.el
+ dodoc README
+}