summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-10-19 20:37:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-10-19 20:37:25 +0000
commit3da5c2082d3d3a451286ea836722f2bd5873c320 (patch)
treed8590be8d23454f823aa8effefb2203a549e0c8b /app-emacs/xtla/xtla-0.1_p525.ebuild
parentKeywords ~amd64. (diff)
downloadgentoo-2-3da5c2082d3d3a451286ea836722f2bd5873c320.tar.gz
gentoo-2-3da5c2082d3d3a451286ea836722f2bd5873c320.tar.bz2
gentoo-2-3da5c2082d3d3a451286ea836722f2bd5873c320.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/xtla/xtla-0.1_p525.ebuild')
-rw-r--r--app-emacs/xtla/xtla-0.1_p525.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/xtla/xtla-0.1_p525.ebuild b/app-emacs/xtla/xtla-0.1_p525.ebuild
new file mode 100644
index 000000000000..5aa4f8a94bf2
--- /dev/null
+++ b/app-emacs/xtla/xtla-0.1_p525.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/xtla/xtla-0.1_p525.ebuild,v 1.1 2004/10/19 20:37:25 mkennedy Exp $
+
+inherit elisp
+
+XTLA_VERSION=${PV:0:3}
+XTLA_PATCH=${PF:10}
+XTLA_REVISION=${PN}--main--${PV:0:3}--patch-${PF:10}
+
+IUSE=""
+
+DESCRIPTION="XTLA - The Emacs interface to GNU TLA"
+HOMEPAGE="http://wiki.gnuarch.org/moin.cgi/xtla
+ https://gna.org/projects/xtla-el
+ http://www.gnu.org/software/gnu-arch/"
+SRC_URI="mirror://gentoo/${PN}--main--${PV:0:3}--patch-${PF:10}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/emacs
+ sys-devel/autoconf
+ sys-devel/automake"
+
+RDEPEND="virtual/emacs
+ dev-util/tla"
+
+S=${WORKDIR}/${XTLA_REVISION}
+
+SITEFILE=50xtla-gentoo.el
+
+src_compile() {
+ autoreconf && ./configure --prefix=/usr
+ make || die
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ doinfo texinfo/xtla.info
+ dodoc INSTALL docs/*
+}