summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-10-08 09:28:15 +0000
committerUlrich Müller <ulm@gentoo.org>2011-10-08 09:28:15 +0000
commita5155503150e8d52aafea87ef30a3522e9afdc3b (patch)
tree2b328fc3e9696a6c05915916a7781dc987723f44 /app-emacs
parentLastrite media-gfx/pngcrush. (diff)
downloadgentoo-2-a5155503150e8d52aafea87ef30a3522e9afdc3b.tar.gz
gentoo-2-a5155503150e8d52aafea87ef30a3522e9afdc3b.tar.bz2
gentoo-2-a5155503150e8d52aafea87ef30a3522e9afdc3b.zip
Update site-init file to use autoloads, bug 385167. Remove redundant src_test function. Install documentation.
(Portage version: 2.1.10.22/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/popwin/ChangeLog7
-rw-r--r--app-emacs/popwin/files/50popwin-gentoo.el7
-rw-r--r--app-emacs/popwin/popwin-0.3.ebuild11
3 files changed, 15 insertions, 10 deletions
diff --git a/app-emacs/popwin/ChangeLog b/app-emacs/popwin/ChangeLog
index 8abb2d6267ea..fa00fd855053 100644
--- a/app-emacs/popwin/ChangeLog
+++ b/app-emacs/popwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/popwin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/ChangeLog,v 1.1 2011/10/01 03:17:25 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/ChangeLog,v 1.2 2011/10/08 09:28:15 ulm Exp $
+
+ 08 Oct 2011; Ulrich Mueller <ulm@gentoo.org> files/50popwin-gentoo.el,
+ popwin-0.3.ebuild:
+ Update site-init file to use autoloads, bug 385167. Remove redundant src_test
+ function. Install documentation.
*popwin-0.3 (01 Oct 2011)
diff --git a/app-emacs/popwin/files/50popwin-gentoo.el b/app-emacs/popwin/files/50popwin-gentoo.el
index 8b21ccc19a4c..bd00744ede00 100644
--- a/app-emacs/popwin/files/50popwin-gentoo.el
+++ b/app-emacs/popwin/files/50popwin-gentoo.el
@@ -1,3 +1,6 @@
(add-to-list 'load-path "@SITELISP@")
-(require 'popwin)
-(setq display-buffer-function 'popwin:display-buffer)
+(autoload 'popwin:display-buffer "popwin"
+ "Display BUFFER-OR-NAME, if possible, in a popup window, or as usual.
+This function can be used as a value of `display-buffer-function'." t)
+(autoload 'popwin:special-display-popup-window "popwin"
+ "The `special-display-function' with a popup window.")
diff --git a/app-emacs/popwin/popwin-0.3.ebuild b/app-emacs/popwin/popwin-0.3.ebuild
index 29777a5d37fc..3ee9fced2911 100644
--- a/app-emacs/popwin/popwin-0.3.ebuild
+++ b/app-emacs/popwin/popwin-0.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/popwin-0.3.ebuild,v 1.1 2011/10/01 03:17:25 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/popwin/popwin-0.3.ebuild,v 1.2 2011/10/08 09:28:15 ulm Exp $
EAPI=3
NEED_EMACS=22
-inherit elisp eutils
+inherit elisp
-DESCRIPTION="popup window manager for Emacs"
+DESCRIPTION="Popup window manager for Emacs"
HOMEPAGE="https://github.com/m2ym/popwin-el/"
SRC_URI="https://github.com/m2ym/popwin-el/tarball/v${PV} -> ${P}.tar.gz"
@@ -17,12 +17,9 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
SITEFILE="50${PN}-gentoo.el"
+DOCS="README.markdown"
src_unpack() {
unpack ${A}
mv m2ym-popwin-el-* ${P} || die
}
-
-src_test() {
- true
-}