summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-18 09:21:49 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-18 09:21:49 +0000
commit01560f63d1747bdeedb54efe1813f994560f1339 (patch)
tree29fec9b86e89e674dc5b1b6edf7b80fc2db00268 /app-emulation/armv8-fast-model
parentadd license for the armv8 system emulator (diff)
downloadgentoo-2-01560f63d1747bdeedb54efe1813f994560f1339.tar.gz
gentoo-2-01560f63d1747bdeedb54efe1813f994560f1339.tar.bz2
gentoo-2-01560f63d1747bdeedb54efe1813f994560f1339.zip
Initial ebuild by me.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation/armv8-fast-model')
-rw-r--r--app-emulation/armv8-fast-model/ChangeLog9
-rw-r--r--app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild48
-rw-r--r--app-emulation/armv8-fast-model/metadata.xml5
3 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/armv8-fast-model/ChangeLog b/app-emulation/armv8-fast-model/ChangeLog
new file mode 100644
index 000000000000..c56613d0e8a4
--- /dev/null
+++ b/app-emulation/armv8-fast-model/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/armv8-fast-model
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/armv8-fast-model/ChangeLog,v 1.1 2014/01/18 09:21:49 vapier Exp $
+
+*armv8-fast-model-0.8.5206 (18 Jan 2014)
+
+ 18 Jan 2014; Mike Frysinger <vapier@gentoo.org>
+ +armv8-fast-model-0.8.5206.ebuild, +metadata.xml:
+ Initial ebuild by me.
diff --git a/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild b/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild
new file mode 100644
index 000000000000..4cf15c102521
--- /dev/null
+++ b/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild,v 1.1 2014/01/18 09:21:49 vapier Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_P="FM000-KT-00035-r${PV:0:1}p${PV:2:1}-${PV:0-4:2}rel${PV:0-2}"
+DESCRIPTION="emulator for a basic ARMv8 platform environment (for running bare metal & Linux)"
+HOMEPAGE="https://silver.arm.com/browse/FM00A"
+SRC_URI="https://silver.arm.com/download/Development_Tools/ESL:_Fast_Models/Fast_Models/${MY_P}/${MY_P}.tgz"
+
+LICENSE="ARM-FAST-MODEL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="examples"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ sys-devel/gcc"
+
+S="${WORKDIR}/Foundation_v8pkg"
+
+QA_PREBUILT="
+ opt/${PN}/bin/Foundation_v8
+ opt/${PN}/*/lib*.so*
+"
+
+pkg_nofetch() {
+ einfo "Please visit this URL to download the package:"
+ einfo " ${SRC_URI}"
+ einfo "Then stick it into ${DISTDIR}"
+}
+
+src_install() {
+ into /opt/${PN}
+ pushd models/Linux64_GCC-4.1 >/dev/null
+ dobin Foundation_v8
+ dolib.so lib*.so*
+ popd >/dev/null
+
+ dodir /opt/bin
+ make_wrapper Foundation_v8 /opt/${PN}/bin/Foundation_v8 '' /opt/${PN}/$(get_libdir) /opt/bin
+
+ dodoc doc/*.{pdf,txt}
+ use examples && dodoc -r examples
+}
diff --git a/app-emulation/armv8-fast-model/metadata.xml b/app-emulation/armv8-fast-model/metadata.xml
new file mode 100644
index 000000000000..5454528f2093
--- /dev/null
+++ b/app-emulation/armv8-fast-model/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>arm</herd>
+</pkgmetadata>