summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-16 02:27:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-16 02:27:44 +0000
commitf5d83012a51800dcbeca0cb78aa35971fcf958eb (patch)
tree3eac57e0c9367288542ec655fbd08ecfd0162439 /app-emulation/cedega
parentuse DESTDIR now (diff)
downloadgentoo-2-f5d83012a51800dcbeca0cb78aa35971fcf958eb.tar.gz
gentoo-2-f5d83012a51800dcbeca0cb78aa35971fcf958eb.tar.bz2
gentoo-2-f5d83012a51800dcbeca0cb78aa35971fcf958eb.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-emulation/cedega')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/cedega-5.1.ebuild61
-rw-r--r--app-emulation/cedega/files/digest-cedega-5.13
3 files changed, 70 insertions, 1 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 97b15282c32c..5494139ec230 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.22 2006/02/11 05:41:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.23 2006/02/16 02:27:44 vapier Exp $
+
+*cedega-5.1 (16 Feb 2006)
+
+ 16 Feb 2006; Mike Frysinger <vapier@gentoo.org> +cedega-5.1.ebuild:
+ Version bump.
11 Feb 2006; Mike Frysinger <vapier@gentoo.org> cedega-4.0.ebuild,
cedega-4.0.1.ebuild, cedega-4.1.ebuild, cedega-4.1.1.ebuild,
diff --git a/app-emulation/cedega/cedega-5.1.ebuild b/app-emulation/cedega/cedega-5.1.ebuild
new file mode 100644
index 000000000000..76ef6e4c35e7
--- /dev/null
+++ b/app-emulation/cedega/cedega-5.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-5.1.ebuild,v 1.1 2006/02/16 02:27:44 vapier Exp $
+
+MY_P="cedega-small-${PV}"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="|| ( ( x11-libs/libX11 ) virtual/x11 )
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ !app-emulation/point2play
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ rm -r "${WORKDIR}"/usr/share/gnome
+ rmdir "${WORKDIR}"/usr/share/* >& /dev/null
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-5.1 b/app-emulation/cedega/files/digest-cedega-5.1
new file mode 100644
index 000000000000..0459f4606853
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-5.1
@@ -0,0 +1,3 @@
+MD5 c0d1215c71358f1f46c264522f737f6b cedega-small-5.1.tgz 1179565
+RMD160 07232527fec76f8e821f88a3722bad3938a4dcfb cedega-small-5.1.tgz 1179565
+SHA256 b64a78b693835f0395b4df9e54be39bd97adfb34f0c6092e260bbe040efc13c0 cedega-small-5.1.tgz 1179565