summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-10 02:13:15 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-10 02:13:15 +0000
commit4c2c7ddc4befffd6fe85351fef50663a19d4ac9c (patch)
tree51487643c72ddda7b29d2de116a6ae47b6b1cfb5 /app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
parentRestore src_unpack(); unpacker.eclass does not automatically detect .sh exten... (diff)
downloadgentoo-2-4c2c7ddc4befffd6fe85351fef50663a19d4ac9c.tar.gz
gentoo-2-4c2c7ddc4befffd6fe85351fef50663a19d4ac9c.tar.bz2
gentoo-2-4c2c7ddc4befffd6fe85351fef50663a19d4ac9c.zip
Restore src_unpack(); unpacker.eclass does not automatically detect .sh extension as a makeself archive (bug #415013, thanks to Alan Smithee).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild')
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
index d456314c6a1d..4a192b992700 100644
--- a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild,v 1.5 2012/02/05 05:27:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild,v 1.6 2012/05/10 02:13:15 tetromino Exp $
inherit unpacker
@@ -31,6 +31,10 @@ pkg_nofetch() {
einfo "and place ${A} in ${DISTDIR}"
}
+src_unpack() {
+ unpack_makeself # needed due to .sh extension; #415013
+}
+
src_install() {
dodir /opt/cxoffice
cp -r * "${D}"/opt/cxoffice || die "cp failed"