summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-08-27 19:49:24 +0000
committerPeter Volkov <pva@gentoo.org>2006-08-27 19:49:24 +0000
commit143485df4a3f160798ba476f6cd87d67a92d6688 (patch)
treedf08fda2a80da06305b97e9dca6168adbbef1b6f /app-emulation/e-uae
parent(#141127) acml.h isn't compatible with cblas.h, so don't symlink it as if it ... (diff)
downloadgentoo-2-143485df4a3f160798ba476f6cd87d67a92d6688.tar.gz
gentoo-2-143485df4a3f160798ba476f6cd87d67a92d6688.tar.bz2
gentoo-2-143485df4a3f160798ba476f6cd87d67a92d6688.zip
Version bump. This is actually 0.8.29-WIP3 with some additional fixes.
(Portage version: 2.1-r1)
Diffstat (limited to 'app-emulation/e-uae')
-rw-r--r--app-emulation/e-uae/ChangeLog9
-rw-r--r--app-emulation/e-uae/e-uae-0.8.29_pre20060812.ebuild128
-rw-r--r--app-emulation/e-uae/files/digest-e-uae-0.8.29_pre200608123
-rw-r--r--app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch44
4 files changed, 183 insertions, 1 deletions
diff --git a/app-emulation/e-uae/ChangeLog b/app-emulation/e-uae/ChangeLog
index 6114d19e3c3d..3e3b0fd246a1 100644
--- a/app-emulation/e-uae/ChangeLog
+++ b/app-emulation/e-uae/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/e-uae
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.16 2006/08/20 09:18:08 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.17 2006/08/27 19:49:24 pva Exp $
+
+*e-uae-0.8.29_pre20060812 (27 Aug 2006)
+
+ 27 Aug 2006; Peter Volkov <pva@gentoo.org>
+ +files/e-uae-xkb-rules-dir-detection.patch,
+ +e-uae-0.8.29_pre20060812.ebuild:
+ Version bump. This is actually 0.8.29-WIP3 with some additional fixes.
20 Aug 2006; Simon Stelling <blubb@gentoo.org> e-uae-0.8.28-r1.ebuild:
stable on amd64
diff --git a/app-emulation/e-uae/e-uae-0.8.29_pre20060812.ebuild b/app-emulation/e-uae/e-uae-0.8.29_pre20060812.ebuild
new file mode 100644
index 000000000000..55a8c619b656
--- /dev/null
+++ b/app-emulation/e-uae/e-uae-0.8.29_pre20060812.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/e-uae-0.8.29_pre20060812.ebuild,v 1.1 2006/08/27 19:49:24 pva Exp $
+
+inherit eutils flag-o-matic
+
+my_ver=${PV%%_pre*}
+snap_ver=${PV##*_pre}
+
+DESCRIPTION="The Ubiquitous Amiga Emulator with an emulation core largely based on WinUAE"
+HOMEPAGE="http://www.rcdrummond.net/uae/"
+#SRC_URI="http://www.rcdrummond.net/uae/${P}/${P}.tar.bz2"
+SRC_URI="http://www.rcdrummond.net/uae/test/${snap_ver}/${PN}-${my_ver}-CVS.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X dga ncurses sdl gtk alsa oss sdl-sound capslib"
+
+# Note: opposed to ./configure --help zlib support required! Check
+# src/Makefile.am that includes zfile.c unconditionaly.
+RDEPEND="X? ( || ( ( x11-libs/libXt
+ x11-libs/libxkbfile
+ x11-libs/libXext
+ dga? ( x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ )
+ virtual/x11
+ )
+ )
+ !X? ( sdl? ( media-libs/libsdl )
+ !sdl? ( sys-libs/ncurses ) )
+ alsa? ( media-libs/alsa-lib )
+ !alsa? ( sdl-sound? ( media-libs/sdl-sound ) )
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ capslib? ( >=games-emulation/caps-20060612 )
+ sys-libs/zlib
+ app-cdr/cdrtools"
+
+DEPEND="$RDEPEND
+ X? ( dga? ( x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto ) )"
+
+S="${WORKDIR}"/${PN}-${my_ver}-CVS
+
+pkg_setup() {
+ # Sound setup.
+ if use alsa; then
+ elog "Choosing alsa as sound target to use."
+ myconf="--with-alsa --without-sdl-sound"
+ elif use sdl-sound ; then
+ if ! use sdl ; then
+ ewarn "sdl-sound is not enabled because sdl is switched off. Leaving"
+ ewarn "sound on oss autodetection."
+ myconf="--without-alsa --without-sdl-sound"
+ ebeep
+ else
+ elog "Choosing sdl-sound as sound target to use."
+ myconf="--without-alsa --with-sdl-sound"
+ fi
+ elif use oss ; then
+ elog "Choosing oss as sound target to use."
+ ewarn "oss will be autodetected. See output of configure."
+ myconf="--without-alsa --without-sdl-sound"
+ else
+ ewarn "There is no alsa, sdl-sound or oss in USE. Sound target disabled!"
+ myconf="--disable-audio"
+ fi
+
+ # VIDEO setup. X is autodetected (there is no --with-X option).
+ if use X ; then
+ elog "Using X11 for video output."
+ myconf="$myconf --without-curses --without-sdl-gfx"
+ use dga && myconf="$myconf --enable-dga --enable-vidmode"
+ elif use sdl ; then
+ elog "Using sdl for video output."
+ myconf="$myconf --with-sdl --with-sdl-gfx --without-curses"
+ elif use ncurses; then
+ elog "Using ncurses for video output."
+ myconf="$myconf --with-curses --without-sdl-gfx"
+ else
+ ewarn "There is no X or sdl or ncurses in USE!"
+ ewarn "Following upstream falling back on ncurses."
+ myconf="$myconf --with-curses --without-sdl-gfx"
+ ebeep
+ fi
+
+ use gtk && myconf="$myconf --enable-ui --enable-threads"
+ use gtk || myconf="$myconf --disable-ui"
+
+ use capslib && myconf="$myconf --with-caps"
+
+ myconf="$myconf --with-zlib"
+
+ # And explicitly state defaults:
+ myconf="$myconf --enable-aga"
+ myconf="$myconf --enable-autoconfig --enable-scsi-device --enable-cdtv --enable-cd32"
+ myconf="$myconf --enable-bsdsock"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-xkb-rules-dir-detection.patch
+ autoreconf
+}
+
+src_compile() {
+ #/usr/share/X11/xkb /usr/lib/X11/xkb /usr/X11R6/lib/X11/xkb
+ strip-flags
+
+ econf ${myconf} \
+ --with-libscg-includedir=/usr/include/scsilib \
+ || die "./configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # Rename it to e-uae
+ mv "${D}/usr/bin/uae" "${D}/usr/bin/${PN}"
+ mv "${D}/usr/bin/readdisk" "${D}/usr/bin/e-readdisk"
+
+ dodoc docs/* README ChangeLog
+}
diff --git a/app-emulation/e-uae/files/digest-e-uae-0.8.29_pre20060812 b/app-emulation/e-uae/files/digest-e-uae-0.8.29_pre20060812
new file mode 100644
index 000000000000..71b0185227ee
--- /dev/null
+++ b/app-emulation/e-uae/files/digest-e-uae-0.8.29_pre20060812
@@ -0,0 +1,3 @@
+MD5 af6c098c714ea1419a75485a743ee4c2 e-uae-0.8.29-CVS.tar.bz2 1057924
+RMD160 465eb38bd9ff870985e85f45c512051edc40ac8d e-uae-0.8.29-CVS.tar.bz2 1057924
+SHA256 4e8e672217cdf1366c32289d7ade02457fc4973fac8efac692b6d40ad0e601d5 e-uae-0.8.29-CVS.tar.bz2 1057924
diff --git a/app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch b/app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch
new file mode 100644
index 000000000000..530bf8ecdde0
--- /dev/null
+++ b/app-emulation/e-uae/files/e-uae-xkb-rules-dir-detection.patch
@@ -0,0 +1,44 @@
+diff -Naur e-uae-0.8.29-CVS.orig/configure.in e-uae-0.8.29-CVS/configure.in
+--- e-uae-0.8.29-CVS.orig/configure.in 2006-08-12 19:59:38.000000000 +0400
++++ e-uae-0.8.29-CVS/configure.in 2006-08-27 23:09:02.000000000 +0400
+@@ -890,7 +890,19 @@
+ ],
+ AC_MSG_RESULT(yes)
+ X_CFLAGS="$X_CFLAGS -DUSE_XKB"
+- X_EXTRA_LIBS="$X_EXTRA_LIBS -lxkbfile",
++ X_EXTRA_LIBS="$X_EXTRA_LIBS -lxkbfile"
++ xkb_rules_dir_found="no"
++ for xkb_rules_dir in /usr/share/X11/xkb/rules /usr/lib/X11/xkb/rules /usr/X11R6/lib/X11/xkb/rules
++ do
++ if test -d $xkb_rules_dir ; then
++ X_CFLAGS="$X_CFLAGS -DXKB_PATH=\\\"$xkb_rules_dir/\\\""
++ xkb_rules_dir_found="yes"
++ break
++ fi
++ done
++ if test "x$xkb_rules_dir_found" = "xno" ; then
++ AC_MSG_ERROR([[Could not find xkb path.]])
++ fi,
+ AC_MSG_RESULT(no)
+ )
+ LIBS=$TMP_SAVE_LIBS
+@@ -933,6 +945,7 @@
+ GFX_CFLAGS="$X_CFLAGS"
+ GFX_CPPFLAGS="-DSHM_SUPPORT_LINKS=$SHM_SUPPORT_LINKS"
+ GFX_LIBS="$X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS"
++
+ fi
+
+
+diff -Naur e-uae-0.8.29-CVS.orig/src/gfx-x11/x11keys.c e-uae-0.8.29-CVS/src/gfx-x11/x11keys.c
+--- e-uae-0.8.29-CVS.orig/src/gfx-x11/x11keys.c 2006-07-06 08:04:58.000000000 +0400
++++ e-uae-0.8.29-CVS/src/gfx-x11/x11keys.c 2006-08-27 23:07:19.000000000 +0400
+@@ -26,7 +26,7 @@
+ # include <X11/XKBlib.h>
+ # include <X11/extensions/XKBrules.h>
+
+-static const char xkb_rules_path[] = "/usr/X11R6/lib/X11/xkb/rules/";
++static const char xkb_rules_path[] = XKB_PATH;
+
+
+ /*