summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-06-13 14:00:48 +0000
committerPeter Volkov <pva@gentoo.org>2006-06-13 14:00:48 +0000
commit9f96f25aeb00e51d51776e3137e451935e7e4cb4 (patch)
treecdb32e36a3ef1f883fe15c93eb127603d0c69a57 /app-emulation/e-uae
parentAdding sdl-sound and capslib for app-emulation/e-uae. (diff)
downloadgentoo-2-9f96f25aeb00e51d51776e3137e451935e7e4cb4.tar.gz
gentoo-2-9f96f25aeb00e51d51776e3137e451935e7e4cb4.tar.bz2
gentoo-2-9f96f25aeb00e51d51776e3137e451935e7e4cb4.zip
Version bump. Fixed modular X deps. Many improvents...
(Portage version: 2.0.54-r2)
Diffstat (limited to 'app-emulation/e-uae')
-rw-r--r--app-emulation/e-uae/ChangeLog10
-rw-r--r--app-emulation/e-uae/Manifest4
-rw-r--r--app-emulation/e-uae/e-uae-0.8.28.ebuild120
-rw-r--r--app-emulation/e-uae/files/digest-e-uae-0.8.281
-rw-r--r--app-emulation/e-uae/metadata.xml6
5 files changed, 137 insertions, 4 deletions
diff --git a/app-emulation/e-uae/ChangeLog b/app-emulation/e-uae/ChangeLog
index 851e052d4877..4c186dc67f79 100644
--- a/app-emulation/e-uae/ChangeLog
+++ b/app-emulation/e-uae/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/e-uae
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.7 2005/06/15 11:12:45 dholm Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.8 2006/06/13 14:00:48 pva Exp $
+
+*e-uae-0.8.28 (13 Jun 2006)
+
+ 13 Jun 2006; Peter Volkov <pva@gentoo.org> metadata.xml,
+ +e-uae-0.8.28.ebuild:
+ Version bump. Fixed modular X deps. Many improvements...
15 Jun 2005; David Holm <dholm@gentoo.org> e-uae-0.8.27.ebuild:
Stable on ppc.
diff --git a/app-emulation/e-uae/Manifest b/app-emulation/e-uae/Manifest
index 2c1d889edc6b..4eef47d3b43f 100644
--- a/app-emulation/e-uae/Manifest
+++ b/app-emulation/e-uae/Manifest
@@ -1,4 +1,6 @@
MD5 cb8f9cfd23cd6327523e4e3f68c61b4b ChangeLog 1121
-MD5 47efa1259484ff2a7d3de539d42b1a90 metadata.xml 371
MD5 624de9bf2b723d7882a4a8e2485f71ef e-uae-0.8.27.ebuild 1635
+MD5 7b69ed58c3317b5e8f25c0be4f04177c e-uae-0.8.28.ebuild 3593
MD5 851c3d9c0e2846a1241c99e5ff19bf01 files/digest-e-uae-0.8.27 66
+MD5 856093362e575805efb4ef8117d8f98c files/digest-e-uae-0.8.28 66
+MD5 107be5d8d010a6b3dac228473128bdf4 metadata.xml 468
diff --git a/app-emulation/e-uae/e-uae-0.8.28.ebuild b/app-emulation/e-uae/e-uae-0.8.28.ebuild
new file mode 100644
index 000000000000..876776d8ed93
--- /dev/null
+++ b/app-emulation/e-uae/e-uae-0.8.28.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/e-uae-0.8.28.ebuild,v 1.1 2006/06/13 14:00:48 pva Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The Eggplant Umiquious Amiga Emulator"
+HOMEPAGE="http://www.rcdrummond.net/uae/"
+SRC_URI="http://www.rcdrummond.net/uae/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X dga ncurses sdl gtk alsa oss sdl-sound capslib"
+
+# app-emulation/e-uae:sdl-sound - Use media-libs/sdl-sound for audio output.
+# app-emulation/e-uae:capslib - Add CAPS library support.
+# Note: opposed to ./configure --help zlib support required! Check
+# src/Makefile.am that includes zfile.c unconditionaly.
+RDEPEND="X? ( || ( ( x11-libs/libXt
+ x11-libs/libxkbfile
+ x11-libs/libXext
+ dga? ( x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ )
+ virtual/x11
+ )
+ )
+ !X? ( sdl? ( media-libs/libsdl )
+ !sdl? ( sys-libs/ncurses ) )
+ alsa? ( media-libs/alsa-lib )
+ !alsa? ( sdl-sound? ( media-libs/sdl-sound ) )
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ capslib? ( games-emulation/caps )
+ sys-libs/zlib
+ app-cdr/cdrtools"
+
+DEPEND="$RDEPEND
+ X? ( dga? ( x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto ) )"
+
+pkg_setup() {
+ # Sound setup.
+ if use alsa; then
+ einfo "Choosing alsa as sound target to use."
+ myconf="--with-alsa --without-sdl-sound"
+ elif use sdl-sound ; then
+ if ! use sdl ; then
+ ewarn "sdl-sound is not enabled because sdl is switched off. Leaving"
+ ewarn "sound on oss autodetection."
+ myconf="--without-alsa --without-sdl-sound"
+ ebeep
+ else
+ einfo "Choosing sdl-sound as sound target to use."
+ myconf="--without-alsa --with-sdl-sound"
+ fi
+ elif use oss ; then
+ einfo "Choosing oss as sound target to use."
+ ewarn "oss will be autodetected. See output of configure."
+ myconf="--without-alsa --without-sdl-sound"
+ else
+ ewarn "There is no alsa, sdl-sound or oss in USE. Sound target disabled!"
+ myconf="--disable-audio"
+ fi
+
+ # VIDEO setup. X is autodetected (there is no --with-X option).
+ if use X ; then
+ myconf="$myconf --without-curses --without-sdl-gfx --enable-vidmode"
+ use dga && myconf="$myconf --enable-dga --enable-vidmode"
+ elif use sdl ; then
+ myconf="$myconf --with-sdl --with-sdl-gfx --without-curses"
+ elif use ncurses; then
+ myconf="$myconf --with-curses --without-sdl-gfx"
+ else
+ ewarn "There is no X or sdl or ncurses in USE!"
+ ewarn "Following upstream falling back on ncurses."
+ myconf="$myconf --with-curses --without-sdl-gfx"
+ ebeep
+ fi
+
+ use gtk && myconf="$myconf --enable-ui --enable-threads"
+ use gtk || myconf="$myconf --disable-ui"
+
+ use capslib && myconf="$myconf --with-caps"
+
+ myconf="$myconf --with-zlib"
+
+ # And explicitly state defaults:
+ myconf="$myconf --enable-aga"
+ myconf="$myconf --enable-autoconfig --enable-scsi-device --enable-cdtv --enable-cd32"
+ myconf="$myconf --enable-bsdsock"
+}
+
+src_compile() {
+ strip-flags
+
+# export WANT_AUTOMAKE=1.7
+# export WANT_AUTOCONF=2.5
+# ./bootstrap.sh || die "bootstrap failed"
+
+ econf ${myconf} \
+ --with-libscg-includedir=/usr/include/scsilib \
+ || die "./configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ insinto /usr/share/uae/amiga-tools
+ doins amiga/{*hack,trans*,uae*,*.library}
+
+ # Rename it to e-uae
+ mv ${D}/usr/bin/uae ${D}/usr/bin/e-uae
+ mv ${D}/usr/bin/readdisk ${D}/usr/bin/e-readdisk
+ mv ${D}/usr/share/uae ${D}/usr/share/${PN}
+
+ dodoc docs/* README ChangeLog CHANGES
+}
diff --git a/app-emulation/e-uae/files/digest-e-uae-0.8.28 b/app-emulation/e-uae/files/digest-e-uae-0.8.28
new file mode 100644
index 000000000000..f84b6f678c51
--- /dev/null
+++ b/app-emulation/e-uae/files/digest-e-uae-0.8.28
@@ -0,0 +1 @@
+MD5 9fc186f9256d04f940304044e29175ef e-uae-0.8.28.tar.bz2 1148790
diff --git a/app-emulation/e-uae/metadata.xml b/app-emulation/e-uae/metadata.xml
index 5cc07509bfa6..6d1f00a1625a 100644
--- a/app-emulation/e-uae/metadata.xml
+++ b/app-emulation/e-uae/metadata.xml
@@ -6,7 +6,11 @@
<email>dholm@gentoo.org</email>
<name>David Holm</name>
</maintainer>
-<longdescription>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription lang="en">
E-UAE is a fork of UAE which intends to merge all the new features of WinUAE with UAE.
</longdescription>
</pkgmetadata>