summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-04-06 09:12:12 +0000
committerPacho Ramos <pacho@gentoo.org>2014-04-06 09:12:12 +0000
commit33d39985a1ea38b2c749d1894b99467a466d6ee3 (patch)
treed0e1afeea0e98216253a5456f100643ae5579fba /app-emulation/emul-linux-x86-sdl
parentInstall missing /usr/include/libimobiledevice/cython/imobiledevice.pxd by han... (diff)
downloadgentoo-2-33d39985a1ea38b2c749d1894b99467a466d6ee3.tar.gz
gentoo-2-33d39985a1ea38b2c749d1894b99467a466d6ee3.tar.bz2
gentoo-2-33d39985a1ea38b2c749d1894b99467a466d6ee3.zip
Version bump, drop old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-emulation/emul-linux-x86-sdl')
-rw-r--r--app-emulation/emul-linux-x86-sdl/ChangeLog10
-rw-r--r--app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20130224.ebuild15
-rw-r--r--app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20140406.ebuild26
3 files changed, 34 insertions, 17 deletions
diff --git a/app-emulation/emul-linux-x86-sdl/ChangeLog b/app-emulation/emul-linux-x86-sdl/ChangeLog
index 57b6f1fa8dd5..5039b32551cc 100644
--- a/app-emulation/emul-linux-x86-sdl/ChangeLog
+++ b/app-emulation/emul-linux-x86-sdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/emul-linux-x86-sdl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-sdl/ChangeLog,v 1.73 2013/12/30 07:45:42 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-sdl/ChangeLog,v 1.74 2014/04/06 09:12:12 pacho Exp $
+
+*emul-linux-x86-sdl-20140406 (06 Apr 2014)
+
+ 06 Apr 2014; Pacho Ramos <pacho@gentoo.org>
+ +emul-linux-x86-sdl-20140406.ebuild, -emul-linux-x86-sdl-20130224.ebuild:
+ Version bump, drop old
*emul-linux-x86-sdl-20131008-r1 (30 Dec 2013)
diff --git a/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20130224.ebuild b/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20130224.ebuild
deleted file mode 100644
index 749ecb691129..000000000000
--- a/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20130224.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20130224.ebuild,v 1.2 2013/03/16 15:23:36 pacho Exp $
-
-EAPI=5
-inherit emul-linux-x86
-
-LICENSE="LGPL-2 LGPL-2.1 ZLIB"
-KEYWORDS="-* amd64"
-
-DEPEND=""
-RDEPEND="~app-emulation/emul-linux-x86-xlibs-${PV}
- ~app-emulation/emul-linux-x86-baselibs-${PV}
- ~app-emulation/emul-linux-x86-soundlibs-${PV}
- ~app-emulation/emul-linux-x86-medialibs-${PV}"
diff --git a/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20140406.ebuild b/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20140406.ebuild
new file mode 100644
index 000000000000..6b537e39a832
--- /dev/null
+++ b/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20140406.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-sdl/emul-linux-x86-sdl-20140406.ebuild,v 1.1 2014/04/06 09:12:12 pacho Exp $
+
+EAPI=5
+inherit emul-linux-x86
+
+LICENSE="LGPL-2 LGPL-2.1 ZLIB"
+KEYWORDS="-* ~amd64"
+IUSE="abi_x86_32"
+
+DEPEND=""
+RDEPEND="~app-emulation/emul-linux-x86-xlibs-${PV}
+ ~app-emulation/emul-linux-x86-baselibs-${PV}
+ ~app-emulation/emul-linux-x86-soundlibs-${PV}
+ ~app-emulation/emul-linux-x86-medialibs-${PV}
+ abi_x86_32? (
+ >=media-libs/openal-1.15.1-r1[abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ emul-linux-x86_src_prepare
+
+ # Remove migrated stuff.
+ use abi_x86_32 && rm -f $(cat "${FILESDIR}/remove-native")
+}