summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-04 19:51:38 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-04 19:51:38 +0000
commit9a6d23892c37146536f46a79c774696cf3e20c40 (patch)
treeff76232ae01db7ae929a6d33d03ba990160fd99f /app-emulation/gxemul
parentadded ~alpha keyword (diff)
downloadgentoo-2-9a6d23892c37146536f46a79c774696cf3e20c40.tar.gz
gentoo-2-9a6d23892c37146536f46a79c774696cf3e20c40.tar.bz2
gentoo-2-9a6d23892c37146536f46a79c774696cf3e20c40.zip
Version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-emulation/gxemul')
-rw-r--r--app-emulation/gxemul/ChangeLog9
-rw-r--r--app-emulation/gxemul/files/digest-gxemul-0.4.4.13
-rw-r--r--app-emulation/gxemul/gxemul-0.4.4.1.ebuild42
3 files changed, 52 insertions, 2 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
index 49f51abbd3d9..b91f7908c51c 100644
--- a/app-emulation/gxemul/ChangeLog
+++ b/app-emulation/gxemul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/gxemul
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.7 2006/11/13 17:21:13 drizzt Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.8 2007/04/04 19:51:38 drizzt Exp $
+
+*gxemul-0.4.4.1 (04 Apr 2007)
+
+ 04 Apr 2007; Timothy Redaelli <drizzt@gentoo.org> +gxemul-0.4.4.1.ebuild:
+ Version bump
13 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> gxemul-0.4.3.ebuild:
Fixed digest on Manifest for 0.4.2.
diff --git a/app-emulation/gxemul/files/digest-gxemul-0.4.4.1 b/app-emulation/gxemul/files/digest-gxemul-0.4.4.1
new file mode 100644
index 000000000000..59c89eb78268
--- /dev/null
+++ b/app-emulation/gxemul/files/digest-gxemul-0.4.4.1
@@ -0,0 +1,3 @@
+MD5 dc13d3dc493d9bb4f302cf255e9f53a4 gxemul-0.4.4.1.tar.gz 2155651
+RMD160 768acba728ad1df8bad734f2009b4dddb96366ca gxemul-0.4.4.1.tar.gz 2155651
+SHA256 2b0ddd0a415ab950e8c6d3a5d950d9b5ce6c68bcaafb5c8ea203e4155dd7775e gxemul-0.4.4.1.tar.gz 2155651
diff --git a/app-emulation/gxemul/gxemul-0.4.4.1.ebuild b/app-emulation/gxemul/gxemul-0.4.4.1.ebuild
new file mode 100644
index 000000000000..4f00d763fdc9
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.4.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.4.1.ebuild,v 1.1 2007/04/04 19:51:38 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+HOMEPAGE="http://gavare.se/gxemul/"
+SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+RDEPEND="X? ( || ( ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXdmcp
+ )
+ virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ X? ( || ( x11-proto/xproto virtual/x11 ) )"
+
+src_compile() {
+ tc-export CC
+ local myconf=""
+
+ use X || myconf="${myconf} --disable-x"
+
+ einfo "Configuring with: ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin gxemul || die "gxemul not found in ${S}"
+ doman man/gxemul.1
+ dodoc HISTORY LICENSE README RELEASE TODO
+ dohtml doc/*
+}