summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-12-31 00:39:39 +0000
committerMike Auty <ikelos@gentoo.org>2008-12-31 00:39:39 +0000
commitd6fd30dbdef15115a10791425dda3a9ce96ee6e8 (patch)
tree6033267a615665d9ea78c3b969328f009fba9e8d /app-emulation/open-vm-tools
parentImport from Science overlay, bug 114094 (diff)
downloadgentoo-2-d6fd30dbdef15115a10791425dda3a9ce96ee6e8.tar.gz
gentoo-2-d6fd30dbdef15115a10791425dda3a9ce96ee6e8.tar.bz2
gentoo-2-d6fd30dbdef15115a10791425dda3a9ce96ee6e8.zip
Version bump, builds with 2.6.27+ and fixes unity/xinerama issue (bug 249293 and bug 247324).
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 i686)
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog11
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20080414.87182.ebuild144
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild (renamed from app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild)72
3 files changed, 43 insertions, 184 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 671f3d3a61b0..24bf2a6af2e8 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.11 2008/11/19 01:34:12 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.12 2008/12/31 00:39:39 ikelos Exp $
+
+*open-vm-tools-0.0.20081223.137496 (31 Dec 2008)
+
+ 31 Dec 2008; Mike Auty <ikelos@gentoo.org>
+ -open-vm-tools-0.0.20080123.74039.ebuild,
+ -open-vm-tools-0.0.20080414.87182.ebuild,
+ +open-vm-tools-0.0.20081223.137496.ebuild:
+ Version bump, builds with 2.6.27+ and fixes unity/xinerama issue (bug
+ 249293 and bug 247324).
19 Nov 2008; Mike Auty <ikelos@gentoo.org>
open-vm-tools-0.0.20080808.109361-r1.ebuild:
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080414.87182.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080414.87182.ebuild
deleted file mode 100644
index c5fd00b69032..000000000000
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080414.87182.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080414.87182.ebuild,v 1.1 2008/04/26 14:04:22 ikelos Exp $
-
-inherit pam eutils linux-mod autotools versionator
-
-MY_DATE="$(get_version_component_range 3)"
-MY_BUILD="$(get_version_component_range 4)"
-MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
-MY_P="${PN}-${MY_PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama"
-DEPEND="
- virtual/linux-sources
- sys-apps/ethtool
- X? (
- x11-libs/libX11
- x11-libs/gtk+
- )
- xinerama? (
- x11-libs/libXinerama
- )
- !app-emulation/vmware-workstation-tools
- !app-emulation/vmware-server-tools
- !app-emulation/vmware-esx-tools
- sys-process/procps
- dev-libs/libdnet
- "
-
-RDEPEND="${DEPEND/virtual\/linux\-sources/}
- virtual/pam
- X? (
- x11-base/xorg-server
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-input-vmmouse
- )
-"
-
-VMWARE_MOD_DIR="modules/linux"
-VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
-
-pkg_setup() {
-
- linux-mod_pkg_setup
- MODULE_NAMES=""
- BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
-
- for mod in ${VMWARE_MODULE_LIST};
- do
- if [[ "${mod}" == "vmxnet" ]];
- then
- MODTARGET="net"
- else
- MODTARGET="openvmtools"
- fi
- MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
- done
-
- ewarn "If you're compiling for a hardened target, please use the hardened"
- ewarn "toolchain (see bug #200376, comment 18)."
-
- enewgroup vmware
-
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # epatch "${FILESDIR}/${PN}-as-needed.patch"
-
- eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_with X x) \
- $(use_enable xinerama multimon) \
- || die "Error: econf failed!"
-
- linux-mod_src_compile
-
- emake || die
-}
-
-src_install() {
-
- linux-mod_src_install
-
- pamd_mimic_system vmware-guestd auth account
-
- # Install the various tools
- cd "${S}"
- VMWARE_BIN_LIST="hgfsclient xferlogs"
- VMWARE_SBIN_LIST="guestd checkvm"
- if use X; then
- # Fix up the vmware-user tool's name
- mv vmware-user/vmware-user vmware-user/user
- mv vmware-user user
- VMWARE_BIN_LIST="${VMWARE_BIN_LIST} user toolbox"
- fi
- for i in ${VMWARE_BIN_LIST}; do
- newbin ${i}/${i} vmware-${i} || die "Failed installing ${i}"
- done
- for i in ${VMWARE_SBIN_LIST}; do
- newsbin ${i}/${i} vmware-${i} || die "Failed installing ${i}"
- done
-
- dolib libguestlib/.libs/libguestlib.{so.0.0.0,a}
-
- # Deal with the hgfsmounter
- into /
- newsbin hgfsmounter/hgfsmounter mount.vmhgfs
- fperms u+s /sbin/mount.vmhgfs
- ### FROM THIS POINT ON, into IS SET TO ${ROOT}/ not ${ROOT}/usr !!!
-
- # Install the /etc/ files
- exeinto /etc/vmware-tools
- doexe scripts/linux/*
- insinto /etc/vmware-tools
- doins "${FILESDIR}/tools.conf"
- # Only install this, when X is being used. Else it's useless waste of
- # ressources when checking continuously for processes that will never appear
- use X && doins "${FILESDIR}/xautostart.conf"
- newinitd "${FILESDIR}/open-vm.initd" vmware-tools
- newconfd "${FILESDIR}/open-vm.confd" vmware-tools
-
- if use X;
- then
- elog "To be able to use the drag'n'drop feature of VMware for file"
- elog "exchange, you need to do this:"
- elog " Add 'vmware-tools' to your default runlevel"
- elog " Add the users which should have access to this function"
- elog " to the group 'vmware'"
- fi
-}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild
index e3a893052eb2..f84e9a6ec746 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild,v 1.2 2008/07/06 19:41:28 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20081223.137496.ebuild,v 1.1 2008/12/31 00:39:39 ikelos Exp $
inherit pam eutils linux-mod versionator
@@ -15,10 +15,10 @@ DESCRIPTION="Opensourced tools for VMware guests"
HOMEPAGE="http://open-vm-tools.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama"
+IUSE="X xinerama icu unity"
DEPEND="
virtual/linux-sources
sys-apps/ethtool
@@ -26,26 +26,40 @@ DEPEND="
x11-libs/libX11
x11-libs/gtk+
)
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
xinerama? (
x11-libs/libXinerama
)
!app-emulation/vmware-workstation-tools
!app-emulation/vmware-server-tools
!app-emulation/vmware-esx-tools
+ sys-process/procps
+ dev-libs/libdnet
+ icu? ( dev-libs/icu )
"
RDEPEND="${DEPEND/virtual\/linux\-sources/}
- X? (
+ virtual/pam
+ X? (
x11-base/xorg-server
x11-drivers/xf86-video-vmware
x11-drivers/xf86-input-vmmouse
- )
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
"
VMWARE_MOD_DIR="modules/linux"
VMWARE_MODULE_LIST="vmblock vmhgfs vmsync vmmemctl vmxnet"
pkg_setup() {
+ use unity && ! use xinerama && \
+ die 'The Unity USE flag requires USE="xinerama" as well'
linux-mod_pkg_setup
MODULE_NAMES=""
@@ -62,16 +76,24 @@ pkg_setup() {
MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
done
- ewarn "If you're compiling for a hardened target, please use the hardened"
- ewarn "toolchain (see bug #200376, comment 18)."
+ ewarn "If you're compiling with a hardened toolchain, please use the"
+ ewarn "hardenednopie gcc profile (see bug #200376, comment 18)."
enewgroup vmware
+}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/default-scripts.patch"
}
src_compile() {
econf \
+ --without-kernel-modules \
+ $(use_with icu) \
$(use_with X x) \
+ $(use_enable unity) \
$(use_enable xinerama multimon) \
|| die "Error: econf failed!"
@@ -86,44 +108,16 @@ src_install() {
pamd_mimic_system vmware-guestd auth account
- # Install the various tools
- cd "${S}"
- VMWARE_BIN_LIST="hgfsclient xferlogs"
- VMWARE_SBIN_LIST="guestd checkvm"
- if use X; then
- # Fix up the vmware-user tool's name
- mv vmware-user/vmware-user vmware-user/user
- mv vmware-user user
- VMWARE_BIN_LIST="${VMWARE_BIN_LIST} user toolbox"
- fi
- for i in ${VMWARE_BIN_LIST}; do
- newbin ${i}/${i} vmware-${i} || die "Failed installing ${i}"
- done
- for i in ${VMWARE_SBIN_LIST}; do
- newsbin ${i}/${i} vmware-${i} || die "Failed installing ${i}"
- done
+ emake install DESTDIR="${D}" || die "Failed to install"
- dolib libguestlib/.libs/libguestlib.{so.0.0.0,a}
-
- # Deal with the hgfsmounter
- into /
- newsbin hgfsmounter/hgfsmounter mount.vmhgfs
- fperms u+s /sbin/mount.vmhgfs
- ### FROM THIS POINT ON, into IS SET TO ${ROOT}/ not ${ROOT}/usr !!!
-
- # Install the /etc/ files
- exeinto /etc/vmware-tools
- doexe scripts/linux/*
- insinto /etc/vmware-tools
- doins "${FILESDIR}/tools.conf"
- # Only install this, when X is being used. Else it's useless waste of
- # ressources when checking continuously for processes that will never appear
- use X && doins "${FILESDIR}/xautostart.conf"
newinitd "${FILESDIR}/open-vm.initd" vmware-tools
newconfd "${FILESDIR}/open-vm.confd" vmware-tools
if use X;
then
+ exeinto /etc/X11/xinit/xinitrc.d
+ doexe "${FILESDIR}/10-vmware-tools"
+
elog "To be able to use the drag'n'drop feature of VMware for file"
elog "exchange, you need to do this:"
elog " Add 'vmware-tools' to your default runlevel"