summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2012-09-12 19:14:11 +0000
committerLuca Barbato <lu_zero@gentoo.org>2012-09-12 19:14:11 +0000
commit24bbb7fc4e17a99fa868a78cad2e445f48e67531 (patch)
tree7709ec813904b62a2e1a2544df0c3c9698352e99 /app-emulation/qemu-user
parentRevision bump, add missing run-time dependencies, needed for compiz-manager s... (diff)
downloadgentoo-2-24bbb7fc4e17a99fa868a78cad2e445f48e67531.tar.gz
gentoo-2-24bbb7fc4e17a99fa868a78cad2e445f48e67531.tar.bz2
gentoo-2-24bbb7fc4e17a99fa868a78cad2e445f48e67531.zip
misc minor fixes
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog5
-rw-r--r--app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index c60fa510510e..28fba9f22658 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.45 2012/06/22 13:52:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.46 2012/09/12 19:14:11 lu_zero Exp $
+
+ 12 Sep 2012; Luca Barbato <lu_zero@gentoo.org> qemu-user-1.1.0-r1.ebuild:
+ misc minor fixes
*qemu-user-1.1.0-r1 (22 Jun 2012)
diff --git a/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild b/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild
index 6bd04835568f..61eb7f54214e 100644
--- a/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild
+++ b/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild,v 1.2 2012/06/25 20:25:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild,v 1.3 2012/09/12 19:14:11 lu_zero Exp $
EAPI=4
@@ -10,7 +10,9 @@ if [[ ${PV} == *9999 ]]; then
GIT_ECLASS="git-2"
fi
-inherit eutils base flag-o-matic pax-utils toolchain-funcs ${GIT_ECLASS}
+PYTHON_DEPEND=2
+
+inherit eutils base flag-o-matic pax-utils toolchain-funcs python ${GIT_ECLASS}
MY_P=${P/-user/}
@@ -72,6 +74,10 @@ QA_WX_LOAD="
usr/bin/qemu-static-mipsn32-binfmt
"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
cd "${S}"
# prevent docs to get automatically installed
@@ -101,7 +107,7 @@ src_configure() {
conf_opts+=" --disable-curses"
conf_opts+=" --disable-sdl"
conf_opts+=" --disable-vde"
- conf_opts+=" --prefix=/usr --disable-bluez --disable-kvm"
+ conf_opts+=" --prefix=/usr --sysconfdir=/etc --disable-bluez --disable-kvm"
conf_opts+=" --cc=$(tc-getCC) --host-cc=$(tc-getBUILD_CC)"
conf_opts+=" --disable-smartcard --disable-smartcard-nss"
conf_opts+=" --extra-ldflags=-Wl,-z,execheap"
@@ -126,7 +132,7 @@ src_install() {
done
pax-mark r "${ED}"/usr/bin/qemu-static-*
- rm -fr "${ED}/usr/share"
+ rm -fr "${ED}/usr/share" "${ED}/usr/libexec" "${ED}/etc"
dohtml qemu-doc.html
dohtml qemu-tech.html
newinitd "${FILESDIR}/qemu-binfmt.initd" qemu-binfmt