summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-09-11 02:24:02 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-09-11 02:24:02 +0000
commit29779a672ca5f636be19e17589fd0fc15b3f7b16 (patch)
tree4e9ea1bc2728c1ee28fc9db53997c25df87d0c0c /app-emulation/qemu-user
parentMark 3.0.2-r1 stable on alpha (diff)
downloadgentoo-2-29779a672ca5f636be19e17589fd0fc15b3f7b16.tar.gz
gentoo-2-29779a672ca5f636be19e17589fd0fc15b3f7b16.tar.bz2
gentoo-2-29779a672ca5f636be19e17589fd0fc15b3f7b16.zip
New version
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/Manifest4
-rw-r--r--app-emulation/qemu-user/files/digest-qemu-user-0.7.21
-rw-r--r--app-emulation/qemu-user/qemu-user-0.7.2.ebuild85
4 files changed, 95 insertions, 2 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index dfd3ede5b880..36c48906741f 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.3 2005/08/06 14:15:36 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.4 2005/09/11 02:24:02 lu_zero Exp $
+
+*qemu-user-0.7.2 (11 Sep 2005)
+
+ 11 Sep 2005; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.7.2.ebuild:
+ New release
06 Aug 2005; Luca Barbato <lu_zero@gentoo.org>
+files/qemu-ppc-dirty-hack.patch, qemu-user-0.7.1.ebuild:
diff --git a/app-emulation/qemu-user/Manifest b/app-emulation/qemu-user/Manifest
index 25cfb2ddddde..ef6850458eaa 100644
--- a/app-emulation/qemu-user/Manifest
+++ b/app-emulation/qemu-user/Manifest
@@ -1,7 +1,9 @@
-MD5 7a02772ebdd2bac1346e7b447e3b8739 ChangeLog 758
+MD5 4af0f0b4cf2b13fc6dfbf3c770d5be6c qemu-user-0.7.2.ebuild 2254
+MD5 3e0dea9e89902703da55b788006f4110 ChangeLog 879
MD5 431458f4c01ad6238f20d77302e4b871 qemu-user-0.7.0-r1.ebuild 2250
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 4af0f0b4cf2b13fc6dfbf3c770d5be6c qemu-user-0.7.1.ebuild 2254
+MD5 19c26d3c7d68ccd1ed3a0f74b7ab467e files/digest-qemu-user-0.7.2 63
MD5 3202f7445799cce82ccaac9749e1443d files/qemu-user-0.7.0-errno.patch 487
MD5 297287b50341a53d302b58ab9ee73a5f files/qemu-ppc-dirty-hack.patch 422
MD5 4fac7d5e68ef58489e7734f5dccb2918 files/digest-qemu-user-0.7.0-r1 63
diff --git a/app-emulation/qemu-user/files/digest-qemu-user-0.7.2 b/app-emulation/qemu-user/files/digest-qemu-user-0.7.2
new file mode 100644
index 000000000000..3f233a874f28
--- /dev/null
+++ b/app-emulation/qemu-user/files/digest-qemu-user-0.7.2
@@ -0,0 +1 @@
+MD5 7d69dd96edf7ae5298a9a7283a0e9fb8 qemu-0.7.2.tar.gz 1341993
diff --git a/app-emulation/qemu-user/qemu-user-0.7.2.ebuild b/app-emulation/qemu-user/qemu-user-0.7.2.ebuild
new file mode 100644
index 000000000000..617bab015824
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.7.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.7.2.ebuild,v 1.1 2005/09/11 02:24:02 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P/-user}.tar.gz"
+#qvm86? ( http://dev.gentoo.org/~lu_zero/distfiles/qvm86-20050409.tar.bz2 )"
+#kqemu? ( http://fabrice.bellard.free.fr/qemu/kqemu-${PV%.*}-1.tar.gz )
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -alpha -sparc ~amd64"
+IUSE="" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc
+ app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${P/-user}"
+
+set_target_list() {
+ TARGET_LIST="arm-user armeb-user i386-user ppc-user sparc-user"
+ export TARGET_LIST
+}
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ ewarn "Qemu could not build with GCC 4"
+ fi
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/qemu-ppc-dirty-hack.patch
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf=""
+ set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ ${myconf} \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ rm -fR ${D}/usr/share/{man,qemu}
+ rm -fR ${D}/usr/bin/qemu-img
+}