summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-11-22 18:47:25 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-11-22 18:47:25 +0000
commita082b628198087b339a95104eaf3e17e3dace110 (patch)
tree781b09d92568d0a76d199878da4c531f094e5249 /app-emulation/qemu-user
parentStable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt b... (diff)
downloadgentoo-2-a082b628198087b339a95104eaf3e17e3dace110.tar.gz
gentoo-2-a082b628198087b339a95104eaf3e17e3dace110.tar.bz2
gentoo-2-a082b628198087b339a95104eaf3e17e3dace110.zip
remove redundant cd and minor cleanup
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/qemu-user-1.0.ebuild16
-rw-r--r--app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild16
-rw-r--r--app-emulation/qemu-user/qemu-user-9999.ebuild16
4 files changed, 20 insertions, 35 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 28fba9f22658..bbd06bfeb9b4 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.46 2012/09/12 19:14:11 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.47 2012/11/22 18:47:25 ago Exp $
+
+ 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> qemu-user-1.0.ebuild,
+ qemu-user-1.1.0-r1.ebuild, qemu-user-9999.ebuild:
+ remove redundant cd and minor cleanup
12 Sep 2012; Luca Barbato <lu_zero@gentoo.org> qemu-user-1.1.0-r1.ebuild:
misc minor fixes
@@ -197,4 +201,3 @@
+files/qemu-user-0.7.0-errno.patch, +metadata.xml,
+qemu-user-0.7.0-r1.ebuild:
qemu split ebuild, abi wrappers
-
diff --git a/app-emulation/qemu-user/qemu-user-1.0.ebuild b/app-emulation/qemu-user/qemu-user-1.0.ebuild
index 9620b84983fa..83b01ace14bc 100644
--- a/app-emulation/qemu-user/qemu-user-1.0.ebuild
+++ b/app-emulation/qemu-user/qemu-user-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-1.0.ebuild,v 1.3 2012/05/03 18:49:08 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-1.0.ebuild,v 1.4 2012/11/22 18:47:25 ago Exp $
EAPI=4
@@ -66,12 +66,11 @@ QA_WX_LOAD="
S="${WORKDIR}/${MY_P}"
src_prepare() {
- cd "${S}"
# prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
# Alter target makefiles to accept CFLAGS set via flag-o
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target
+ Makefile Makefile.target || die
EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" epatch
@@ -104,12 +103,8 @@ src_configure() {
./configure ${conf_opts} --target-list="${user_targets}" || die "econf failed"
}
-src_compile() {
- emake || die "emake qemu failed"
-}
-
src_install() {
- emake DESTDIR="${ED}" install || die "make install failed"
+ emake DESTDIR="${ED}" install
# fixup to avoid collisions with qemu
base_dir="${ED}/usr/bin"
@@ -120,7 +115,6 @@ src_install() {
pax-mark r "${ED}"/usr/bin/qemu-static-*
rm -fr "${ED}/usr/share"
- dohtml qemu-doc.html
- dohtml qemu-tech.html
+ dohtml qemu-doc.html qemu-tech.html
newinitd "${FILESDIR}/qemu-binfmt.initd" qemu-binfmt
}
diff --git a/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild b/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild
index 61eb7f54214e..b77a29cd4e12 100644
--- a/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild
+++ b/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild,v 1.3 2012/09/12 19:14:11 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-1.1.0-r1.ebuild,v 1.4 2012/11/22 18:47:25 ago Exp $
EAPI=4
@@ -79,12 +79,11 @@ pkg_setup() {
}
src_prepare() {
- cd "${S}"
# prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
# Alter target makefiles to accept CFLAGS set via flag-o
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target
+ Makefile Makefile.target || die
EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" epatch
@@ -117,12 +116,8 @@ src_configure() {
./configure ${conf_opts} --target-list="${user_targets}" || die "econf failed"
}
-src_compile() {
- emake || die "emake qemu failed"
-}
-
src_install() {
- emake DESTDIR="${ED}" install || die "make install failed"
+ emake DESTDIR="${ED}" install
# fixup to avoid collisions with qemu
base_dir="${ED}/usr/bin"
@@ -133,7 +128,6 @@ src_install() {
pax-mark r "${ED}"/usr/bin/qemu-static-*
rm -fr "${ED}/usr/share" "${ED}/usr/libexec" "${ED}/etc"
- dohtml qemu-doc.html
- dohtml qemu-tech.html
+ dohtml qemu-doc.html qemu-tech.html
newinitd "${FILESDIR}/qemu-binfmt.initd" qemu-binfmt
}
diff --git a/app-emulation/qemu-user/qemu-user-9999.ebuild b/app-emulation/qemu-user/qemu-user-9999.ebuild
index 776103abfbbc..276369322353 100644
--- a/app-emulation/qemu-user/qemu-user-9999.ebuild
+++ b/app-emulation/qemu-user/qemu-user-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-9999.ebuild,v 1.3 2012/06/22 13:52:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-9999.ebuild,v 1.4 2012/11/22 18:47:25 ago Exp $
EAPI=4
@@ -73,12 +73,11 @@ QA_WX_LOAD="
"
src_prepare() {
- cd "${S}"
# prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
# Alter target makefiles to accept CFLAGS set via flag-o
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target
+ Makefile Makefile.target || die
EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" epatch
@@ -111,12 +110,8 @@ src_configure() {
./configure ${conf_opts} --target-list="${user_targets}" || die "econf failed"
}
-src_compile() {
- emake || die "emake qemu failed"
-}
-
src_install() {
- emake DESTDIR="${ED}" install || die "make install failed"
+ emake DESTDIR="${ED}" install
# fixup to avoid collisions with qemu
base_dir="${ED}/usr/bin"
@@ -127,7 +122,6 @@ src_install() {
pax-mark r "${ED}"/usr/bin/qemu-static-*
rm -fr "${ED}/usr/share"
- dohtml qemu-doc.html
- dohtml qemu-tech.html
+ dohtml qemu-doc.html qemu-tech.html
newinitd "${FILESDIR}/qemu-binfmt.initd" qemu-binfmt
}