summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-05 08:24:32 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-05 08:24:32 +0000
commitdf05fd00c48bc4bc301e95ae867b2af711a92d2e (patch)
tree5cf5cf0699a4fa30e68df4bbeb5030f344982c58 /app-emulation/qemu
parentAdd USE=lzo/snappy to control liblzo/snappy automagic deps. (diff)
downloadgentoo-2-df05fd00c48bc4bc301e95ae867b2af711a92d2e.tar.gz
gentoo-2-df05fd00c48bc4bc301e95ae867b2af711a92d2e.tar.bz2
gentoo-2-df05fd00c48bc4bc301e95ae867b2af711a92d2e.zip
Add USE=numa to control numactl automagic dep.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog6
-rw-r--r--app-emulation/qemu/metadata.xml1
-rw-r--r--app-emulation/qemu/qemu-2.1.0.ebuild6
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild6
4 files changed, 14 insertions, 5 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 01b5d1a53095..fa15d91ba1e1 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.277 2014/08/05 08:21:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.278 2014/08/05 08:24:32 vapier Exp $
+
+ 05 Aug 2014; Mike Frysinger <vapier@gentoo.org> metadata.xml,
+ qemu-2.1.0.ebuild, qemu-9999.ebuild:
+ Add USE=numa to control numactl automagic dep.
05 Aug 2014; Mike Frysinger <vapier@gentoo.org> metadata.xml,
qemu-2.0.0-r1.ebuild, qemu-2.1.0.ebuild, qemu-9999.ebuild:
diff --git a/app-emulation/qemu/metadata.xml b/app-emulation/qemu/metadata.xml
index 59b54295eb03..7276a657c2ae 100644
--- a/app-emulation/qemu/metadata.xml
+++ b/app-emulation/qemu/metadata.xml
@@ -20,6 +20,7 @@
<flag name='mixemu'>Enable audio mixer emulation. On Fedora, known to cause performance problems when using SDL output and ALSA. For OSS, locks the sound device from other applications.</flag>
<flag name='ncurses'>Enable the ncurses-based console</flag>
<flag name='nfs'>Enable NFS support</flag>
+ <flag name='numa'>Enable NUMA support</flag>
<flag name='pulseaudio'>Enable pulseaudio output for sound emulation</flag>
<flag name='rbd'>Enable rados block device backend support, see http://ceph.newdream.net/wiki/QEMU-RBD</flag>
<flag name='sdl'>Enable the SDL-based console</flag>
diff --git a/app-emulation/qemu/qemu-2.1.0.ebuild b/app-emulation/qemu/qemu-2.1.0.ebuild
index 58735ef087bf..c98829ae0919 100644
--- a/app-emulation/qemu/qemu-2.1.0.ebuild
+++ b/app-emulation/qemu/qemu-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.4 2014/08/05 08:21:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.5 2014/08/05 08:24:32 vapier Exp $
EAPI=5
@@ -31,7 +31,7 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
gtk iscsi +jpeg \
-kernel_linux kernel_FreeBSD lzo ncurses nfs nls opengl +png pulseaudio python \
+kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
virtfs +vnc xattr xen xfs"
@@ -74,6 +74,7 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
lzo? ( dev-libs/lzo:2[static-libs(+)] )
ncurses? ( sys-libs/ncurses[static-libs(+)] )
nfs? ( net-fs/libnfs[static-libs(+)] )
+ numa? ( sys-process/numactl[static-libs(+)] )
png? ( media-libs/libpng[static-libs(+)] )
rbd? ( sys-cluster/ceph[static-libs(+)] )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)] )
@@ -335,6 +336,7 @@ qemu_src_configure() {
$(use_enable lzo)
$(use_enable ncurses curses)
$(use_enable nfs libnfs)
+ $(use_enable numa)
$(use_enable opengl glx)
$(use_enable png vnc-png)
$(use_enable rbd)
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 978b623d9abb..3429cb8c27d5 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.82 2014/08/05 08:21:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.83 2014/08/05 08:24:32 vapier Exp $
EAPI=5
@@ -31,7 +31,7 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
gtk iscsi +jpeg \
-kernel_linux kernel_FreeBSD lzo ncurses nfs nls opengl +png pulseaudio python \
+kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
virtfs +vnc xattr xen xfs"
@@ -74,6 +74,7 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
lzo? ( dev-libs/lzo:2[static-libs(+)] )
ncurses? ( sys-libs/ncurses[static-libs(+)] )
nfs? ( net-fs/libnfs[static-libs(+)] )
+ numa? ( sys-process/numactl[static-libs(+)] )
png? ( media-libs/libpng[static-libs(+)] )
rbd? ( sys-cluster/ceph[static-libs(+)] )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)] )
@@ -335,6 +336,7 @@ qemu_src_configure() {
$(use_enable lzo)
$(use_enable ncurses curses)
$(use_enable nfs libnfs)
+ $(use_enable numa)
$(use_enable opengl glx)
$(use_enable png vnc-png)
$(use_enable rbd)