summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-27 02:23:57 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-27 02:23:57 +0000
commit5fcd33a0ed23fea1e578b59053b9cd689a3db7dd (patch)
tree783c965471e78ab9877f2907782ca291ee8571b3 /app-emulation/simh
parentversion bump (diff)
downloadgentoo-2-5fcd33a0ed23fea1e578b59053b9cd689a3db7dd.tar.gz
gentoo-2-5fcd33a0ed23fea1e578b59053b9cd689a3db7dd.tar.bz2
gentoo-2-5fcd33a0ed23fea1e578b59053b9cd689a3db7dd.zip
Version bump.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/simh')
-rw-r--r--app-emulation/simh/ChangeLog9
-rw-r--r--app-emulation/simh/files/digest-simh-3.5.21
-rw-r--r--app-emulation/simh/simh-3.5.2.ebuild50
3 files changed, 58 insertions, 2 deletions
diff --git a/app-emulation/simh/ChangeLog b/app-emulation/simh/ChangeLog
index 725333e07c2a..e92d041a5250 100644
--- a/app-emulation/simh/ChangeLog
+++ b/app-emulation/simh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/simh
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.4 2005/10/29 12:37:26 grobian Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.5 2006/01/27 02:23:57 vapier Exp $
+
+*simh-3.5.2 (27 Jan 2006)
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org> +simh-3.5.2.ebuild:
+ Version bump.
29 Oct 2005; Fabian Groffen <grobian@gentoo.org> simh-3.5.0.ebuild:
Marked ~ppc-macos (bug #108768)
diff --git a/app-emulation/simh/files/digest-simh-3.5.2 b/app-emulation/simh/files/digest-simh-3.5.2
new file mode 100644
index 000000000000..4d950393a9dd
--- /dev/null
+++ b/app-emulation/simh/files/digest-simh-3.5.2
@@ -0,0 +1 @@
+MD5 e3d2a168f2da62e10e0013f1f9111d82 simhv35-2.zip 2259795
diff --git a/app-emulation/simh/simh-3.5.2.ebuild b/app-emulation/simh/simh-3.5.2.ebuild
new file mode 100644
index 000000000000..115e504041e5
--- /dev/null
+++ b/app-emulation/simh/simh-3.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.5.2.ebuild,v 1.1 2006/01/27 02:23:57 vapier Exp $
+
+inherit eutils versionator
+
+MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
+DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
+HOMEPAGE="http://simh.trailing-edge.com/"
+SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-macos ~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
+
+
+src_unpack() {
+ mkdir "${WORKDIR}/BIN"
+ unpack ${A}
+
+ # convert makefile from dos format to unix format
+ sed -i 's/.$//' makefile
+
+ epatch "${FILESDIR}/makefile.patch"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}/BIN"
+ for BINFILE in *; do
+ newbin ${BINFILE} "simh-${BINFILE}"
+ done
+
+ cd ${S}
+ dodir /usr/share/simh
+ insinto /usr/share/simh
+ doins VAX/*.bin
+ dodoc *.txt */*.txt
+}