summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-17 04:01:05 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-17 04:01:05 +0000
commitc3a263c6189802ab9f385fee35c2ba4795e1cc8c (patch)
tree2b4e37b7e52114ecd04ca88ad1d81129b760267b /app-emulation/ski
parentRemove old version, version bump w/ CONFIG_BATMAN_ADV_DEBUG=y support (thanks... (diff)
downloadgentoo-2-c3a263c6189802ab9f385fee35c2ba4795e1cc8c.tar.gz
gentoo-2-c3a263c6189802ab9f385fee35c2ba4795e1cc8c.tar.bz2
gentoo-2-c3a263c6189802ab9f385fee35c2ba4795e1cc8c.zip
Fix flag handling with gtk/x11, and broken big endian configure logic #412173 by Arseny Solokha.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ski')
-rw-r--r--app-emulation/ski/ChangeLog8
-rw-r--r--app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch75
-rw-r--r--app-emulation/ski/files/ski-1.3.2-configure-withval.patch22
-rw-r--r--app-emulation/ski/files/ski-1.3.2-gtk-linkage.patch13
-rw-r--r--app-emulation/ski/ski-1.3.2.ebuild19
5 files changed, 129 insertions, 8 deletions
diff --git a/app-emulation/ski/ChangeLog b/app-emulation/ski/ChangeLog
index 033dc9be9b57..151a5a4bec2f 100644
--- a/app-emulation/ski/ChangeLog
+++ b/app-emulation/ski/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ski
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ChangeLog,v 1.1 2012/04/16 05:04:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ChangeLog,v 1.2 2012/04/17 04:01:05 vapier Exp $
+
+ 17 Apr 2012; Mike Frysinger <vapier@gentoo.org> ski-1.3.2.ebuild,
+ +files/ski-1.3.2-AC_C_BIGENDIAN.patch,
+ +files/ski-1.3.2-configure-withval.patch, +files/ski-1.3.2-gtk-linkage.patch:
+ Fix flag handling with gtk/x11, and broken big endian configure logic #412173
+ by Arseny Solokha.
*ski-1.3.2 (16 Apr 2012)
diff --git a/app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch b/app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch
new file mode 100644
index 000000000000..34a7d8183702
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-AC_C_BIGENDIAN.patch
@@ -0,0 +1,75 @@
+use standard AC_C_BIGENDIAN macro rather than trying to define it manually
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -155,52 +155,24 @@ AC_SUBST(GSKI_CFLAGS)
+ AC_SUBST(GSKI_LIBS)
+ AM_CONDITIONAL(WITH_GTK_INTERFACE, test "x$with_gtk" = "xyes")
+
+-dnl Target endianness
+-AC_ARG_ENABLE(bigendian,
+-AC_HELP_STRING([--enable-bigendian],
+- [the target is big endian default=no]),
+-ski_cv_c_target_bigendian=${enableval}, ski_cv_c_target_bigendian=no)
+-
+ dnl Check for host endianness
+ AC_CACHE_CHECK([whether host byte ordering is defined in sys/param.h],
+ ski_cv_c_bigendian_compile,
+ [AC_TRY_COMPILE([
+ #include <sys/types.h>
+ #include <sys/param.h>
+ ],[
+ #if !BYTE_ORDER || !BIG_ENDIAN || !LITTLE_ENDIAN
+ #error bogus endian macros
+ #endif
+ ],
+ ski_cv_c_bigendian_compile=yes, ski_cv_c_bigendian_compile=no)])
+
+ if test "x$ski_cv_c_bigendian_compile" = xyes; then
+ AC_DEFINE(ENDIANESS_IN_SYS_PARAM_H, 1,
+ [define if sys/param.h defines the endiness])
+-else
+-AC_CACHE_CHECK([whether host byte ordering is big endian],
+-ski_cv_c_bigendian,
+-[AC_TRY_RUN([int main () {
+- union {
+- long l;
+- char c[sizeof (long)];
+- } u;
+- u.l = 1;
+- return (u.c[sizeof (long) - 1] == 1);
+-}],
+-ski_cv_c_bigendian=no, ski_cv_c_bigendian=yes,
+-AC_MSG_ERROR([cannot detect host endianness]))])
+-
+-AC_DEFINE(BIG_ENDIAN, 4321, [define to 4321 if missing from sys/param.h])
+-AC_DEFINE(LITTLE_ENDIAN, 1234, [define to 4321 if missing from sys/param.h])
+-if test "x$ski_cv_c_bigendian" = xyes; then
+- AC_DEFINE(BYTE_ORDER, 4321,
+- [define to 4321 if host is big endian, 1234 if little endian])
+-else
+- AC_DEFINE(BYTE_ORDER, 1234,
+- [define to 4321 if host is big endian, 1234 if little endian])
+-fi
+ fi
++AC_C_BIGENDIAN
+
+ dnl Check for variables & functions
+
+--- a/src/std.h
++++ b/src/std.h
+@@ -62,6 +62,14 @@ extern unsigned long long __strtoull(const char *, char **, int);
+ # define BIG_ENDIAN 4321
+ # define LITTLE_ENDIAN 1234
+ # define BYTE_ORDER BIG_ENDIAN
++# else
++# define BIG_ENDIAN 4321
++# define LITTLE_ENDIAN 1234
++# ifdef WORDS_BIGENDIAN
++# define BYTE_ORDER BIG_ENDIAN
++# else
++# define BYTE_ORDER LITTLE_ENDIAN
++# endif
+ # endif /* !defined HAVE_CONFIG_H */
+ #endif /* !defined ENDIANESS_IN_SYS_PARAM_H */
+
diff --git a/app-emulation/ski/files/ski-1.3.2-configure-withval.patch b/app-emulation/ski/files/ski-1.3.2-configure-withval.patch
new file mode 100644
index 000000000000..7bb3ce9fc85c
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-configure-withval.patch
@@ -0,0 +1,22 @@
+fix handling of 3rd/4th args to AC_ARG_WITH()
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -130,7 +130,7 @@ dnl See if we build X11
+ AC_ARG_WITH(x11,
+ AC_HELP_STRING([--with-x11],
+ [Enable the Motif based X11 interface default=no]),
+- [with_x11=yes],[with_x11=no])
++ [with_x11=$withval])
+
+ if test "x$with_x11" = "xyes"; then
+ dnl Check for motif, error out if not found
+@@ -144,7 +144,7 @@ dnl See if we build GTK
+ AC_ARG_WITH(gtk,
+ AC_HELP_STRING([--with-gtk],
+ [Enable building the GTK Ski interface default=no]),
+- [with_gtk=yes],[with_gtk=no]
++ [with_gtk=$withval]
+ )
+
+ if test "x$with_gtk" = "xyes"; then
diff --git a/app-emulation/ski/files/ski-1.3.2-gtk-linkage.patch b/app-emulation/ski/files/ski-1.3.2-gtk-linkage.patch
new file mode 100644
index 000000000000..089f84be43a8
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-gtk-linkage.patch
@@ -0,0 +1,13 @@
+we don't link against libgnome, but we do gtk, so fix the pkg-config call
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -148,7 +148,7 @@ AC_HELP_STRING([--with-gtk],
+ )
+
+ if test "x$with_gtk" = "xyes"; then
+- PKG_CHECK_MODULES([GSKI], [libglade-2.0 libgnomeui-2.0 >= 1.110.0])
++ PKG_CHECK_MODULES([GSKI], [libglade-2.0 gtk+-2.0])
+ AC_DEFINE(HAVE_GTK, 1, [define if you have GTK support])
+ fi
+ AC_SUBST(GSKI_CFLAGS)
diff --git a/app-emulation/ski/ski-1.3.2.ebuild b/app-emulation/ski/ski-1.3.2.ebuild
index 22367434810b..b752ee13fa68 100644
--- a/app-emulation/ski/ski-1.3.2.ebuild
+++ b/app-emulation/ski/ski-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ski-1.3.2.ebuild,v 1.1 2012/04/16 05:04:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ski-1.3.2.ebuild,v 1.2 2012/04/17 04:01:05 vapier Exp $
EAPI="4"
@@ -26,11 +26,16 @@ DEPEND="${RDEPEND}
sys-devel/flex
dev-util/gperf"
+PATCHES=(
+ "${FILESDIR}"/${P}-syscall-linux-includes.patch
+ "${FILESDIR}"/${P}-remove-hayes.patch
+ "${FILESDIR}"/${P}-no-local-ltdl.patch
+ "${FILESDIR}"/${P}-AC_C_BIGENDIAN.patch
+ "${FILESDIR}"/${P}-configure-withval.patch
+)
+
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-syscall-linux-includes.patch \
- "${FILESDIR}"/${P}-remove-hayes.patch \
- "${FILESDIR}"/${P}-no-local-ltdl.patch
+ epatch "${PATCHES[@]}"
rm -rf libltdl src/ltdl.[ch] macros/ltdl.m4
@@ -40,6 +45,6 @@ src_prepare() {
src_configure() {
econf \
--without-included-ltdl \
- $(use_enable gtk) \
- $(use_enable motif x11)
+ $(use_with gtk) \
+ $(use_with motif x11)
}