summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBartosch Pixa <darkspecter@gentoo.org>2003-03-03 15:45:03 +0000
committerBartosch Pixa <darkspecter@gentoo.org>2003-03-03 15:45:03 +0000
commite5f2f2d3e06ab30387113b821192da3ad7352ff8 (patch)
treedc8b2aeb7c84e5ebe98d298bd6e891c755e1c8a8 /app-emulation/snes9x
parentbump (diff)
downloadgentoo-2-e5f2f2d3e06ab30387113b821192da3ad7352ff8.tar.gz
gentoo-2-e5f2f2d3e06ab30387113b821192da3ad7352ff8.tar.bz2
gentoo-2-e5f2f2d3e06ab30387113b821192da3ad7352ff8.zip
added patch to fix issues on hardware that doesn't support AFMT_S16_LE
Diffstat (limited to 'app-emulation/snes9x')
-rw-r--r--app-emulation/snes9x/ChangeLog5
-rw-r--r--app-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff26
-rw-r--r--app-emulation/snes9x/snes9x-139-r1.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/app-emulation/snes9x/ChangeLog b/app-emulation/snes9x/ChangeLog
index 82c89a7f7f04..741af856bc79 100644
--- a/app-emulation/snes9x/ChangeLog
+++ b/app-emulation/snes9x/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/snes9x
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.10 2003/02/20 21:58:26 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.11 2003/03/03 15:45:02 darkspecter Exp $
*snes9x-139-r1 (20 Feb 2003)
+ 03 Mar 2003; Bartosch Pixa <darkspecter@gentoo.org> snes9x-139-r1.ebuild:
+ BE sound fix
+
20 Feb 2003; Bartosch Pixa <darkspecter@gentoo.org> snes9x-139-r1.ebuild :
added a patch to enable fallback to c routines, RDEPEND and set ~ppc in keywords
diff --git a/app-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff b/app-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff
new file mode 100644
index 000000000000..b24de16d41c1
--- /dev/null
+++ b/app-emulation/snes9x/files/snes9x-139-r1-BE-sound-fix.diff
@@ -0,0 +1,26 @@
+--- release/unix/unix.cpp.orig 2003-03-02 03:33:54.000000000 +0100
++++ release/unix/unix.cpp 2003-03-02 03:35:10.000000000 +0100
+@@ -1463,7 +1463,11 @@
+ perror ("ioctl SNDCTL_DSP_SETTRIGGER");
+ #endif
+
++#ifdef MSB_FIRST
++ J = AFMT_S16_BE;
++#else
+ J = AFMT_S16_LE;
++#endif
+ // J = AFMT_U8;
+ if (ioctl (so.sound_fd, SNDCTL_DSP_SETFMT, &J) < 0)
+ {
+@@ -1471,7 +1475,11 @@
+ return (FALSE);
+ }
+
++#ifdef MSB_FIRST
++ if (J != AFMT_S16_BE)
++#else
+ if (J != AFMT_S16_LE)
++#endif
+ {
+ so.sixteen_bit = FALSE;
+ J = AFMT_U8;
diff --git a/app-emulation/snes9x/snes9x-139-r1.ebuild b/app-emulation/snes9x/snes9x-139-r1.ebuild
index 9b94ad8e92c6..a6f2f98fe399 100644
--- a/app-emulation/snes9x/snes9x-139-r1.ebuild
+++ b/app-emulation/snes9x/snes9x-139-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.14 2003/02/24 01:16:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.15 2003/03/03 15:45:03 darkspecter Exp $
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="http://www.snes9x.com/"
@@ -40,6 +40,7 @@ src_compile() {
patch -p1 < ${FILESDIR}/snes9x-gcc3.diff
if [ `use ppc` ]; then
patch -p1 < ${FILESDIR}/snes9x-139-r1-Makefile-ppc.diff
+ patch -p1 < ${FILESDIR}/snes9x-139-r1-BE-sound-fix.diff
fi
#install our custom CXXFLAGS