summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-10-04 17:08:40 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-10-04 17:08:40 +0000
commitd5028441e251bded43f7723591573b324241cf3d (patch)
treeccccb0836fecae3bc425382479d9f1d8cdbe6f91 /app-emulation/spice-vdagent
parentFix up to use console-kit correctly. bug #431890 (diff)
downloadgentoo-2-d5028441e251bded43f7723591573b324241cf3d.tar.gz
gentoo-2-d5028441e251bded43f7723591573b324241cf3d.tar.bz2
gentoo-2-d5028441e251bded43f7723591573b324241cf3d.zip
Version bump
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice-vdagent')
-rw-r--r--app-emulation/spice-vdagent/ChangeLog7
-rw-r--r--app-emulation/spice-vdagent/spice-vdagent-0.12.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-emulation/spice-vdagent/ChangeLog b/app-emulation/spice-vdagent/ChangeLog
index d2b01300d5c3..5ac1ac79594c 100644
--- a/app-emulation/spice-vdagent/ChangeLog
+++ b/app-emulation/spice-vdagent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/spice-vdagent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.9 2012/10/04 17:08:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.10 2012/10/04 17:08:40 cardoe Exp $
+
+*spice-vdagent-0.12.0 (04 Oct 2012)
+
+ 04 Oct 2012; Doug Goldstein <cardoe@gentoo.org> +spice-vdagent-0.12.0.ebuild:
+ Version bump
04 Oct 2012; Doug Goldstein <cardoe@gentoo.org> spice-vdagent-0.10.1.ebuild:
Fix up to use console-kit correctly. bug #431890
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.12.0.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.12.0.ebuild
new file mode 100644
index 000000000000..914d1e73c0df
--- /dev/null
+++ b/app-emulation/spice-vdagent/spice-vdagent-0.12.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/spice-vdagent-0.12.0.ebuild,v 1.1 2012/10/04 17:08:40 cardoe Exp $
+
+EAPI=4
+
+inherit linux-info
+
+DESCRIPTION="SPICE VD Linux Guest Agent."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+consolekit"
+
+RDEPEND="x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXinerama
+ >=x11-libs/libpciaccess-0.10
+ >=app-emulation/spice-protocol-0.10.1
+ consolekit? ( sys-auth/consolekit sys-apps/dbus )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
+ERROR_INPUT_UINPUT="User level input support is required"
+ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support is required"
+
+src_configure() {
+ local opt=
+
+ use consolekit && opt="${opt} --with-session-info=console-kit"
+
+ econf \
+ --localstatedir=/var \
+ ${opt}
+}
+
+src_install() {
+ default
+
+ rm -rf "${D}"/etc/{rc,tmpfiles}.d
+
+ keepdir /var/run/spice-vdagentd
+ keepdir /var/log/spice-vdagentd
+
+ newinitd "${FILESDIR}/${PN}.initd-2" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
+}