summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-04 21:04:15 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-04 21:04:15 +0000
commitab16032acd0e8f3c5c07116cef6a74869f65d7b3 (patch)
tree264c8606404c06f5b932f47db4305cf700df5c8b /app-emulation/uae
parentfixing fftw depend. (Manifest recommit) (diff)
downloadgentoo-2-ab16032acd0e8f3c5c07116cef6a74869f65d7b3.tar.gz
gentoo-2-ab16032acd0e8f3c5c07116cef6a74869f65d7b3.tar.bz2
gentoo-2-ab16032acd0e8f3c5c07116cef6a74869f65d7b3.zip
Cleanup submitted by Jonathan Heaney
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog6
-rw-r--r--app-emulation/uae/files/install_libscg_gentoo27
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild14
3 files changed, 9 insertions, 38 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 02373a615a14..0c65d3ff164b 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.13 2004/03/04 20:05:05 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.14 2004/03/04 21:04:12 dholm Exp $
+
+ 04 Mar 2004; David Holm <dholm@gentoo.org> uae-0.8.25_pre20040302.ebuild,
+ files/install_libscg_gentoo:
+ Cleanup submitted by Jonathan Heaney.
*uae-0.8.25_pre20040302 (04 Mar 2004)
diff --git a/app-emulation/uae/files/install_libscg_gentoo b/app-emulation/uae/files/install_libscg_gentoo
deleted file mode 100644
index 4670d5b72eae..000000000000
--- a/app-emulation/uae/files/install_libscg_gentoo
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-#
-# copy those files that are necessary to use the libscg
-# in UAE ON GENTOO
-#
-# Patrick Ohly, 9.4.2000, GPL
-#
-# Updated for cdrtools 2.0.x Richard Drummond 15.2.2004
-# Ripped to pieces by Jonathan Heaney 23.2.2004
-#
-# check arguments
-#
-libsdir=/usr/lib
-incsdir=/usr/include
-scsiinc="$incsdir"/scsilib
-
-#
-# find our own directory
-# hint: this file is in src
-#
-uaedir=`dirname "$0"`
-
-cp -R -f -L "$scsiinc/btorder.h" "$scsiinc/intcvt.h" "$scsiinc/mconfig.h" \
- "$scsiinc/prototyp.h" "$scsiinc/utypes.h" "$scsiinc/scg" \
- "$incsdir/xconfig.h" "$uaedir"/include
-cp -f "$libsdir/libscg.a" \
- "$libsdir/libschily.a" "$uaedir"
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
index c4db6b94b086..0ef924c0e572 100644
--- a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.1 2004/03/04 20:05:05 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.2 2004/03/04 21:04:12 dholm Exp $
inherit flag-o-matic
@@ -18,26 +18,20 @@ IUSE="X gtk sdl"
DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
( ncurses? sys-libs/ncurses svga? media-libs/svgalib )
sdl? media-libs/libsdl
- games-emulation/caps
- app-cdr/cdrtools"
+ app-cdr/cdrtools
+ games-emulation/caps"
src_compile() {
ewarn "Compiling the CPU-core requires a substantial amount of RAM."
ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
- # copy over dirty scsi copy script
- cp ${FILESDIR}/install_libscg_gentoo ${S}/src
- # and run
- /bin/sh ${S}/src/install_libscg_gentoo
-
replace-flags "-O3" "-O2"
use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
econf ${myconf} \
--enable-threads \
--enable-scsi-device \
- --enable-cdtv \
- --enable-cd32 \
+ --with-libscg-includedir=/usr/include/scsilib \
|| die "./configure failed"
emake -j1 || die "emake failed"