summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-07-16 13:23:16 +0000
committerDavid Holm <dholm@gentoo.org>2004-07-16 13:23:16 +0000
commitcbaea4c98fa6211758e0625711e2aa0229225204 (patch)
tree009ae99a48b298f20aedbdd562e4dcd1e78e36a4 /app-emulation/uae
parentUpdates for gaim-0.80 (Manifest recommit) (diff)
downloadgentoo-2-cbaea4c98fa6211758e0625711e2aa0229225204.tar.gz
gentoo-2-cbaea4c98fa6211758e0625711e2aa0229225204.tar.bz2
gentoo-2-cbaea4c98fa6211758e0625711e2aa0229225204.zip
Strip -msse and -msse2 from x86 build flags
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog5
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild3
2 files changed, 6 insertions, 2 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 86a131f970a4..2c0ce0f038b1 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.18 2004/06/24 22:35:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.19 2004/07/16 13:23:16 dholm Exp $
+
+ 16 Jul 2004; David Holm <dholm@gentoo.org> uae-0.8.25_pre20040302.ebuild:
+ Strip -msse and -msse2 as they break compilation on x86.
24 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> uae-0.8.22.ebuild,
uae-0.8.23_pre20040129.ebuild, uae-0.8.25_pre20040302.ebuild:
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
index e750e0f0fe43..9ed348bc2a8d 100644
--- a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.8 2004/06/27 23:07:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.9 2004/07/16 13:23:16 dholm Exp $
inherit flag-o-matic
@@ -31,6 +31,7 @@ DEPEND="virtual/libc
src_compile() {
# -O3 breaks compilation, GCC will eat all your RAM + Swap and die
replace-flags "-O3" "-O2"
+ use x86 && strip-flags "-msse" "-msse2"
use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
cp ${FILESDIR}/split_cpuemu.pl ${S}/src