summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-02-04 17:48:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-02-04 17:48:38 +0000
commit2084cf16d940c93052a62ba5d5647b8f5d9122e6 (patch)
tree1a3eca6e9fac15ab207af108a6dab74d8fb38348 /app-emulation/virt-manager
parentStable for HPPA (bug #302285). (diff)
downloadgentoo-2-2084cf16d940c93052a62ba5d5647b8f5d9122e6.tar.gz
gentoo-2-2084cf16d940c93052a62ba5d5647b8f5d9122e6.tar.bz2
gentoo-2-2084cf16d940c93052a62ba5d5647b8f5d9122e6.zip
fix issue when nc doesn't handle the EOF on socket close correctly. According to upstream Debian has an issue with it but they're patching up their nc to respect EOF better. So, the only solution is to kill the ssh tunnel instead of just assuming it'll close eventually
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/ChangeLog14
-rw-r--r--app-emulation/virt-manager/files/virt-manager-0.8.2-ssh-tunnel-shutdown.patch20
-rw-r--r--app-emulation/virt-manager/virt-manager-0.8.2-r1.ebuild36
3 files changed, 68 insertions, 2 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index efcc514ed919..7ba6d35805f4 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/virt-manager
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.24 2009/12/23 17:19:47 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.25 2010/02/04 17:48:37 cardoe Exp $
+
+*virt-manager-0.8.2-r1 (04 Feb 2010)
+
+ 04 Feb 2010; Doug Goldstein <cardoe@gentoo.org>
+ +virt-manager-0.8.2-r1.ebuild,
+ +files/virt-manager-0.8.2-ssh-tunnel-shutdown.patch:
+ fix issue when nc doesn't handle the EOF on socket close correctly.
+ According to upstream Debian has an issue with it but they're patching up
+ their nc to respect EOF better. So, the only solution is to kill the ssh
+ tunnel instead of just assuming it'll close eventually
23 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Drop unused local flag.
diff --git a/app-emulation/virt-manager/files/virt-manager-0.8.2-ssh-tunnel-shutdown.patch b/app-emulation/virt-manager/files/virt-manager-0.8.2-ssh-tunnel-shutdown.patch
new file mode 100644
index 000000000000..cc7040a3e732
--- /dev/null
+++ b/app-emulation/virt-manager/files/virt-manager-0.8.2-ssh-tunnel-shutdown.patch
@@ -0,0 +1,20 @@
+diff -Nur virt-manager-0.8.2/src/virtManager/console.py virt-manager-0.8.2-ssh-tunnel/src/virtManager/console.py
+--- virt-manager-0.8.2/src/virtManager/console.py 2009-12-14 16:40:30.000000000 -0600
++++ virt-manager-0.8.2-ssh-tunnel/src/virtManager/console.py 2010-02-04 11:40:17.000000000 -0600
+@@ -29,6 +29,7 @@
+ import gtkvnc
+ import os
+ import socket
++import signal
+
+ from virtManager.error import vmmErrorDialog
+
+@@ -534,7 +535,7 @@
+ logging.debug("Shutting down tunnel PID %d FD %d" %
+ (self.vncTunnel[1], self.vncTunnel[0].fileno()))
+ self.vncTunnel[0].close()
+- os.waitpid(self.vncTunnel[1], 0)
++ os.kill(self.vncTunnel[1], signal.SIGTERM)
+ self.vncTunnel = None
+
+ def try_login(self, src=None):
diff --git a/app-emulation/virt-manager/virt-manager-0.8.2-r1.ebuild b/app-emulation/virt-manager/virt-manager-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..f6bba773b19a
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-0.8.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.8.2-r1.ebuild,v 1.1 2010/02/04 17:48:37 cardoe Exp $
+
+EAPI=2
+
+# Stop gnome2.eclass from doing stuff on USE=debug
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="A graphical tool for administering virtual machines (KVM/Xen)"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring"
+RDEPEND=">=dev-lang/python-2.4.0
+ >=dev-python/pygtk-1.99.12
+ >=app-emulation/libvirt-0.4.5[python]
+ >=dev-libs/libxml2-2.6.23[python]
+ >=app-emulation/virtinst-0.500.1
+ >=gnome-base/librsvg-2
+ >=x11-libs/vte-0.12.2[python]
+ >=net-libs/gtk-vnc-0.3.4[python]
+ >=dev-python/dbus-python-0.61
+ >=dev-python/gconf-python-1.99.11
+ dev-python/libgnome-python
+ gnome-keyring? ( dev-python/gnome-keyring-python )"
+DEPEND="${RDEPEND}
+ app-text/rarian"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ssh-tunnel-shutdown.patch
+}