summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-06-25 03:51:18 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-06-25 03:51:18 +0000
commitccfbe4d8755aa97edc083615fac7fde41b74efee (patch)
tree112f4022d8cdb8540326e6a911a57c7898867423 /app-emulation/virt-manager
parentUpdate init.d scripts to use vars from the config file. Disable growl by def... (diff)
downloadgentoo-2-ccfbe4d8755aa97edc083615fac7fde41b74efee.tar.gz
gentoo-2-ccfbe4d8755aa97edc083615fac7fde41b74efee.tar.bz2
gentoo-2-ccfbe4d8755aa97edc083615fac7fde41b74efee.zip
Handful of eclass usage fixes. Nothing like getting our GNOME/gconf/gsettings bits to play nice with our new Python eclass bits.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/ChangeLog7
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0.ebuild18
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild18
3 files changed, 14 insertions, 29 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index e29d6b414356..8e6dad5cd02e 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.81 2013/06/24 13:28:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.82 2013/06/25 03:51:18 cardoe Exp $
+
+ 25 Jun 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0.ebuild,
+ virt-manager-9999.ebuild:
+ Handful of eclass usage fixes. Nothing like getting our GNOME/gconf/gsettings
+ bits to play nice with our new Python eclass bits.
*virt-manager-9999 (24 Jun 2013)
*virt-manager-0.10.0 (24 Jun 2013)
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
index 26f0cb8d012d..d11020687de7 100644
--- a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.1 2013/06/24 13:28:45 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.2 2013/06/25 03:51:18 cardoe Exp $
EAPI=5
@@ -9,7 +9,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
#PYTHON_REQ_USE=""
-inherit eutils distutils-r1 fdo-mime gnome2-utils
+inherit eutils gnome2 distutils-r1
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="http://virt-manager.org"
@@ -32,8 +32,10 @@ RDEPEND="!app-emulation/virtinst
x11-libs/gtk+:3[introspection]
>=app-emulation/libvirt-0.7.0[python]
>=app-emulation/libvirt-glib-0.0.9
+ ${PYTHON_DEPS}
dev-libs/libxml2[python,${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/urlgrabber[${PYTHON_USEDEP}]
x11-libs/vte:2.90[glade,introspection]
gnome-keyring? ( dev-python/gnome-keyring-python )
@@ -61,15 +63,3 @@ distutils-r1_python_compile() {
--qemu-user=qemu \
--default-graphics=${defgraphics}
}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- fdo-mime_desktop_database_update
-}
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index e8890c5df40a..5a4ccc91aa85 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.14 2013/06/24 13:28:45 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.15 2013/06/25 03:51:18 cardoe Exp $
EAPI=5
@@ -9,7 +9,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
#PYTHON_REQ_USE=""
-inherit eutils distutils-r1 fdo-mime gnome2-utils
+inherit eutils gnome2 distutils-r1
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="http://virt-manager.org"
@@ -32,8 +32,10 @@ RDEPEND="!app-emulation/virtinst
x11-libs/gtk+:3[introspection]
>=app-emulation/libvirt-0.7.0[python]
>=app-emulation/libvirt-glib-0.0.9
+ ${PYTHON_DEPS}
dev-libs/libxml2[python,${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/urlgrabber[${PYTHON_USEDEP}]
x11-libs/vte:2.90[glade,introspection]
gnome-keyring? ( dev-python/gnome-keyring-python )
@@ -61,15 +63,3 @@ distutils-r1_python_compile() {
--qemu-user=qemu \
--default-graphics=${defgraphics}
}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- fdo-mime_desktop_database_update
-}