summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-09 21:00:50 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-09 21:00:50 +0000
commit833de678a8249ad60439730343e353203b44c40e (patch)
treeca26b642a46fc7706748a64e7695d7d9be205170 /app-emulation/vmware-workstation
parentfixed patch (diff)
downloadgentoo-2-833de678a8249ad60439730343e353203b44c40e.tar.gz
gentoo-2-833de678a8249ad60439730343e353203b44c40e.tar.bz2
gentoo-2-833de678a8249ad60439730343e353203b44c40e.zip
Added config2 patch to make /etc/vmware/config writable by the vmware group and closing bug #114993.
(Portage version: 2.0.53)
Diffstat (limited to 'app-emulation/vmware-workstation')
-rw-r--r--app-emulation/vmware-workstation/ChangeLog8
-rw-r--r--app-emulation/vmware-workstation/files/vmware-workstation-5.5.0.18463-config2.patch14
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild8
3 files changed, 27 insertions, 3 deletions
diff --git a/app-emulation/vmware-workstation/ChangeLog b/app-emulation/vmware-workstation/ChangeLog
index f2f02b95ca32..bcd01b448908 100644
--- a/app-emulation/vmware-workstation/ChangeLog
+++ b/app-emulation/vmware-workstation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vmware-workstation
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/ChangeLog,v 1.106 2005/11/28 22:35:56 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/ChangeLog,v 1.107 2005/12/09 21:00:50 wolf31o2 Exp $
+
+ 09 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/vmware-workstation-5.5.0.18463-config2.patch,
+ vmware-workstation-5.5.0.18463.ebuild:
+ Added config2 patch to make /etc/vmware/config writable by the vmware group
+ and closing bug #114993.
*vmware-workstation-5.0.0.13124-r4 (28 Nov 2005)
*vmware-workstation-4.5.2.8848-r9 (28 Nov 2005)
diff --git a/app-emulation/vmware-workstation/files/vmware-workstation-5.5.0.18463-config2.patch b/app-emulation/vmware-workstation/files/vmware-workstation-5.5.0.18463-config2.patch
new file mode 100644
index 000000000000..6c5243a73598
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/vmware-workstation-5.5.0.18463-config2.patch
@@ -0,0 +1,14 @@
+--- vmware-config.pl 2005-12-09 15:06:24.000000000 -0500
++++ vmware-config.pl.orig 2005-12-04 13:41:36.000000000 -0500
+@@ -7327,10 +7327,7 @@
+ error('Unable to write configuration file "' . $name . '".' . "\n\n");
+ }
+ db_add_file($name, 0x1);
+- safe_chmod(0664, $name);
+- my $gid = (getgrnam('vmware'))[2];
+- my $uid = (stat($name))[4];
+- safe_chown($uid,$gid,$name);
++ safe_chmod(0644, $name);
+
+ # Append the promotional configuration if it exists
+ $promoconfig = $libdir . '/configurator/PROMOCONFIG';
diff --git a/app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild b/app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild
index f0d260df7c10..615f430d03ea 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild,v 1.1 2005/11/28 14:33:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-5.5.0.18463.ebuild,v 1.2 2005/12/09 21:00:50 wolf31o2 Exp $
# Unlike many other binary packages the user doesn't need to agree to a licence
# to download VMWare. The agreeing to a licence is part of the configure step
@@ -56,6 +56,8 @@ src_unpack() {
cd ${S}
# patch the config to not install desktop/icon files
epatch ${FILESDIR}/${P}-config.patch
+ # patch the config to make /etc/vmware/config writable
+ epatch ${FILESDIR}/${P}-config2.patch
# unpack ${ANY_ANY}.tar.gz
# mv -f ${ANY_ANY}/*.tar ${S}/lib/modules/source/
# cd ${S}/${ANY_ANY}
@@ -134,8 +136,10 @@ src_install() {
chown -R root:0 ${D} || die
# this makes the vmware-vmx executable only executable by vmware group
- fowners root:vmware ${dir}/lib/bin{,-debug}/vmware-vmx || die
+ fowners root:vmware ${dir}/lib/bin{,-debug}/vmware-vmx /etc/vmware/config \
+ || die "Changing permissions"
fperms 4750 ${dir}/lib/bin{,-debug}/vmware-vmx || die
+ fperms 770 /etc/vmware /etc/vmware/config || die
# this adds udev rules for vmmon*
dodir /etc/udev/rules.d