summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-04 00:52:31 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-04 00:52:31 +0000
commitc66a8febc5ca248edc47ccfa0531fa98ee5d090e (patch)
treee968e50d0249e7766e9a0fd3bfa88c7d45288f8a /app-emulation/win4lin/win4lin-4.0.20.ebuild
parentwhitespace cleanup (diff)
downloadgentoo-2-c66a8febc5ca248edc47ccfa0531fa98ee5d090e.tar.gz
gentoo-2-c66a8febc5ca248edc47ccfa0531fa98ee5d090e.tar.bz2
gentoo-2-c66a8febc5ca248edc47ccfa0531fa98ee5d090e.zip
whitespace cleanup
Diffstat (limited to 'app-emulation/win4lin/win4lin-4.0.20.ebuild')
-rw-r--r--app-emulation/win4lin/win4lin-4.0.20.ebuild68
1 files changed, 34 insertions, 34 deletions
diff --git a/app-emulation/win4lin/win4lin-4.0.20.ebuild b/app-emulation/win4lin/win4lin-4.0.20.ebuild
index fd5c191dc72f..46dcc706b93e 100644
--- a/app-emulation/win4lin/win4lin-4.0.20.ebuild
+++ b/app-emulation/win4lin/win4lin-4.0.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-4.0.20.ebuild,v 1.2 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-4.0.20.ebuild,v 1.3 2003/09/04 00:52:29 msterret Exp $
IUSE="doc"
@@ -11,7 +11,7 @@ DESCRIPTION="Win4Lin allows you run Windows applications somewhat natively
under linux."
HOMEPAGE="http://www.netraverse.com/"
SRC_URI="mirror://gentoo/${MY_P}.rpm
- doc? ( https://www.netraverse.com/support/docs/Win4Lin-4.0.0-manual.pdf )"
+ doc? ( https://www.netraverse.com/support/docs/Win4Lin-4.0.0-manual.pdf )"
SLOT="0"
LICENSE="NeTraverse"
@@ -21,59 +21,59 @@ DEPEND="app-arch/rpm2targz
sys-kernel/win4lin-sources"
src_unpack() {
- rpm2targz ${DISTDIR}/${MY_P}.rpm
- tar zxf ${WORKDIR}/${MY_P}.tar.gz
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
}
src_compile() {
- einfo "nothing to compile; binary package."
+ einfo "nothing to compile; binary package."
}
src_install() {
- mv ${S}/opt ${D}
- mv ${S}/etc ${D}
- cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
+ mv ${S}/opt ${D}
+ mv ${S}/etc ${D}
+ cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
- if [ -n "`use doc`" ]
- then
- dodoc ${DISTDIR}/Win4Lin-4.0.0-manual.pdf
- fi
+ if [ -n "`use doc`" ]
+ then
+ dodoc ${DISTDIR}/Win4Lin-4.0.0-manual.pdf
+ fi
}
pkg_postinst() {
- /opt/win4lin/postinst_rpm.sh
+ /opt/win4lin/postinst_rpm.sh
echo "LICENSE_CODE=1w4e053x-n0aaf8-7tw9-587j-h47j-d6" > /var/win4lin/install/license.lic
einfo "If this is a new Win4Lin Install you will need to run the following command"
- einfo "ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
- einfo "to install the windows setup files. You will need your Windows cdrom in the "
- einfo "drive in order to complete this step."
+ einfo "ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
+ einfo "to install the windows setup files. You will need your Windows cdrom in the "
+ einfo "drive in order to complete this step."
}
pkg_prerm() {
- /opt/win4lin/remove_rpm.sh
+ /opt/win4lin/remove_rpm.sh
}
pkg_config() {
- loadwindowsCD cddevice /dev/cdrom
- ln -s /etc/rc.d/init.d/Win4Lin /etc/init.d/Win4Lin
- #put debugging stuff here
- if [ ${?} -eq "0" ]; then
- einfo "You can now run the command \"installwindows\" from an xterm "
- einfo "as a non-root user to install a personal copy of Windows that Win4Lin "
- einfo "will use for that user."
- einfo
- einfo "Win4Lin is a commercial product, you now are using a evaluation-license"
- einfo "for 15 days evaluation. If you want a extra 15 days of evaluation you"
- einfo 'must run "sh /opt/win4lin/registerme.sh"'
- einfo
- einfo 'You can help Gentoo Linux and obatin a full license at a discont offer'
- einfo 'for gentoo users in http://www.netraverse.com/gentoo.htm'
- einfo 'Netraverse donate to Gentoo Linux a percent of each purchase.'
- einfo 'Thanks Netaverse.'
+ loadwindowsCD cddevice /dev/cdrom
+ ln -s /etc/rc.d/init.d/Win4Lin /etc/init.d/Win4Lin
+#put debugging stuff here
+ if [ ${?} -eq "0" ]; then
+ einfo "You can now run the command \"installwindows\" from an xterm "
+ einfo "as a non-root user to install a personal copy of Windows that Win4Lin "
+ einfo "will use for that user."
+ einfo
+ einfo "Win4Lin is a commercial product, you now are using a evaluation-license"
+ einfo "for 15 days evaluation. If you want a extra 15 days of evaluation you"
+ einfo 'must run "sh /opt/win4lin/registerme.sh"'
+ einfo
+ einfo 'You can help Gentoo Linux and obatin a full license at a discont offer'
+ einfo 'for gentoo users in http://www.netraverse.com/gentoo.htm'
+ einfo 'Netraverse donate to Gentoo Linux a percent of each purchase.'
+ einfo 'Thanks Netaverse.'
einfo
einfo 'Remember, you must do "/etc/init.d/Win4Lin start" before start w4l'
einfo 'Also you can add it to default boot "rc-update add Win4Lin default"'
- fi
+ fi
}