summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2012-03-30 11:55:14 +0000
committerJosé María Alonso <nimiux@gentoo.org>2012-03-30 11:55:14 +0000
commit831d070acd797b5cf8c7718fa3b22e03805db05e (patch)
tree02393443253e7f3bdf5776b65997478bbb837933 /app-emulation/x48
parentinitial import, ebuild by Guillaume Horel in bug #406519 (diff)
downloadgentoo-2-831d070acd797b5cf8c7718fa3b22e03805db05e.tar.gz
gentoo-2-831d070acd797b5cf8c7718fa3b22e03805db05e.tar.bz2
gentoo-2-831d070acd797b5cf8c7718fa3b22e03805db05e.zip
Version bump. Released version 0.6.4.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/x48')
-rw-r--r--app-emulation/x48/ChangeLog7
-rw-r--r--app-emulation/x48/x48-0.6.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-emulation/x48/ChangeLog b/app-emulation/x48/ChangeLog
index d18ce8b19c1d..fc020c85ab3d 100644
--- a/app-emulation/x48/ChangeLog
+++ b/app-emulation/x48/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/x48
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.21 2012/03/20 20:52:56 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.22 2012/03/30 11:55:14 nimiux Exp $
+
+*x48-0.6.4 (30 Mar 2012)
+
+ 30 Mar 2012; Chema Alonso <nimiux@gentoo.org> +x48-0.6.4.ebuild:
+ Version bump. Released version 0.6.4.
20 Mar 2012; Chema Alonso <nimiux@gentoo.org> metadata.xml:
Added myself as maintainer
diff --git a/app-emulation/x48/x48-0.6.4.ebuild b/app-emulation/x48/x48-0.6.4.ebuild
new file mode 100644
index 000000000000..98e155095718
--- /dev/null
+++ b/app-emulation/x48/x48-0.6.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.6.4.ebuild,v 1.1 2012/03/30 11:55:14 nimiux Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="HP48 Calculator Emulator"
+HOMEPAGE="http://x48.berlios.de/"
+SRC_URI="mirror://sourceforge/x48.berlios/${P}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-libs/libXt"
+
+src_unpack() {
+ mkdir -p "${S}"
+ cd "${S}"
+ unpack ${A}
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto /usr/share/"${PN}"/romdump
+ doins -r romdump/{README,ROMDump*}
+ dodoc AUTHORS README ChangeLog
+}
+
+pkg_postinst() {
+ elog "The X48 emulator requires an HP48 ROM image to run."
+ elog
+ elog "If you own an HP-48 calculator, you can use the ROMDump utility"
+ elog "included with this package to obtain it from your calculator."
+ elog "The instructions of how to do this are included in the package."
+ elog
+ elog "Alternatively, HP has provided the ROM images for non-commercial"
+ elog "use only."
+ elog
+ elog "Due to confusion over the legal status of these ROMs you must"
+ elog "manually download one from http://www.hpcalc.org/hp48/pc/emulators/"
+ elog
+ elog "If you do not know which one to use, try 'HP 48GX Revision R ROM.'"
+ elog
+ elog "Once you have a ROM, you will need to install it by running:"
+ elog
+ elog "x48 -rom gxrom-r"
+ elog
+ elog "You will only have to do this the first time you run X48. The"
+ elog "ROM will be stored in ~/.hp48/rom for future runs."
+}