summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-30 14:12:30 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-30 14:12:30 +0000
commit5eb4cbf2dcf7cc574ef7ae2c6081344cfbf5954b (patch)
tree6378e6ad55add4799da3661c00a32f5f1fd92995 /app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild
parentVersion bump. Switch to EAPI=5 and drop old. (diff)
downloadgentoo-2-5eb4cbf2dcf7cc574ef7ae2c6081344cfbf5954b.tar.gz
gentoo-2-5eb4cbf2dcf7cc574ef7ae2c6081344cfbf5954b.tar.bz2
gentoo-2-5eb4cbf2dcf7cc574ef7ae2c6081344cfbf5954b.zip
revbump; -4.2.0-r1, python eclass added to enable & ensure a py2 build wrt Bug 53930, xen-4-fix_dotconfig-gcc.patch, xen-4.2.0-externals.patch upgraded 1 sec. patch added, -4.2.1-r1 mirrors changes of -4.2.0-r1, -j1 workaround fixed in -jserver.patch also in -4.2.0.
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild')
-rw-r--r--app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild b/app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild
index c6ffd2658f9e..560887f36597 100644
--- a/app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild
+++ b/app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild,v 1.1 2013/01/28 05:29:05 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.2.1.ebuild,v 1.2 2013/01/30 14:12:30 idella4 Exp $
EAPI="4"
@@ -29,7 +29,7 @@ IUSE="custom-cflags"
DEPEND="sys-devel/gettext
sys-devel/gcc"
-RDEPEND="=app-emulation/xen-${PV}"
+RDEPEND=">=app-emulation/xen-4.2.1"
src_prepare() {
@@ -67,6 +67,9 @@ src_prepare() {
# Drop .config and Fix gcc-4.6
epatch "${FILESDIR}"/${PN/-pvgrub/}-4-fix_dotconfig-gcc.patch
+
+ # fix jobserver in Makefile
+ epatch "${FILESDIR}"/${PN/-pvgrub/}-4.2.0-jserver.patch
}
src_compile() {
@@ -79,14 +82,14 @@ src_compile() {
# TODO; fix those -j1
if use x86; then
- emake -j1 CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
elif use amd64; then
- emake -j1 CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub
if use multilib; then
multilib_toolchain_setup x86
- emake -j1 XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
+ emake XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
fi
fi
}