summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-26 19:16:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-26 19:16:00 +0000
commit52079146ef7ab962d7d3f022b4b27fe77c87c685 (patch)
tree6087d31db60137df01cdf6550c4b7fcf5c046833 /app-emulation/xen-tools
parentEnable introspection by default, per gnome policy. (diff)
downloadgentoo-2-52079146ef7ab962d7d3f022b4b27fe77c87c685.tar.gz
gentoo-2-52079146ef7ab962d7d3f022b4b27fe77c87c685.tar.bz2
gentoo-2-52079146ef7ab962d7d3f022b4b27fe77c87c685.zip
[app-emulation/xen-tools] Fix build on some platforms
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/ChangeLog5
-rw-r--r--app-emulation/xen-tools/xen-tools-4.1.0.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 259c89da9ab7..f5d88e4eb792 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.70 2011/03/26 18:43:04 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.71 2011/03/26 19:16:00 alexxy Exp $
+
+ 26 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-tools-4.1.0.ebuild:
+ Fix build on some platforms
26 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-tools-4.1.0.ebuild:
Fix bug #360561
diff --git a/app-emulation/xen-tools/xen-tools-4.1.0.ebuild b/app-emulation/xen-tools/xen-tools-4.1.0.ebuild
index 7e5c69cc9ed3..87275eee60d4 100644
--- a/app-emulation/xen-tools/xen-tools-4.1.0.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.1.0.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.0.ebuild,v 1.2 2011/03/26 18:43:04 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.0.ebuild,v 1.3 2011/03/26 19:16:00 alexxy Exp $
EAPI="3"
inherit flag-o-matic eutils multilib python
-# TPMEMUFILE=tpm_emulator-0.4.tar.gz
-
DESCRIPTION="Xend daemon and tools"
HOMEPAGE="http://xen.org/"
SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
@@ -110,7 +108,9 @@ pkg_setup() {
}
src_prepare() {
- sed -i -e 's/-Wall//' Config.mk || die "Couldn't sanitize CFLAGS"
+ sed -e 's/-Wall//' -i Config.mk || die "Couldn't sanitize CFLAGS"
+ # Drop .config
+ sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
# if the user *really* wants to use their own custom-cflags, let them
if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"
@@ -127,18 +127,18 @@ src_prepare() {
# Disable hvm support on systems that don't support x86_32 binaries.
if ! use hvm; then
chmod 644 tools/check/check_x11_devel
- sed -i -e '/^CONFIG_IOEMU := y$/d' "${S}"/config/*.mk
- sed -i -e '/SUBDIRS-$(CONFIG_X86) += firmware/d' "${S}"/tools/Makefile
+ sed -e '/^CONFIG_IOEMU := y$/d' -i config/*.mk
+ sed -e '/SUBDIRS-$(CONFIG_X86) += firmware/d' -i tools/Makefile
fi
if ! use pygrub; then
- sed -i -e '/^SUBDIRS-$(PYTHON_TOOLS) += pygrub$/d' "${S}"/tools/Makefile
+ sed -e '/^SUBDIRS-$(PYTHON_TOOLS) += pygrub$/d' -i tools/Makefile
fi
# Don't bother with ioemu, only needed for fully virtualised guests
if ! use ioemu; then
- sed -i -e "/^CONFIG_IOEMU := y$/d" "${S}"/config/*.mk
- sed -i -e "s:install-tools\: tools/ioemu-dir:install-tools\: :g" \
- "${S}/Makefile"
+ sed -e "/^CONFIG_IOEMU := y$/d" -i config/*.mk
+ sed -e "s:install-tools\: tools/ioemu-dir:install-tools\: :g" \
+ -i Makefile
fi
# Fix network broadcast on bridged networks
epatch "${FILESDIR}/${PN}-3.4.0-network-bridge-broadcast.patch"