summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-05-07 21:16:08 +0000
committerLance Albertson <ramereth@gentoo.org>2010-05-07 21:16:08 +0000
commit022f0ad1f292e9e588ae93731b47f3af29b89925 (patch)
tree83d331c0dd24e45b3ac636db55d867f553942d50 /app-emulation
parentPackage moved from app-admin to sys-boot. (diff)
downloadgentoo-2-022f0ad1f292e9e588ae93731b47f3af29b89925.tar.gz
gentoo-2-022f0ad1f292e9e588ae93731b47f3af29b89925.tar.bz2
gentoo-2-022f0ad1f292e9e588ae93731b47f3af29b89925.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-htools/ChangeLog8
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.2.5.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/app-emulation/ganeti-htools/ChangeLog b/app-emulation/ganeti-htools/ChangeLog
index 64dc7ba23dea..744d1cc7bc95 100644
--- a/app-emulation/ganeti-htools/ChangeLog
+++ b/app-emulation/ganeti-htools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-htools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.1 2010/03/11 17:14:00 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.2 2010/05/07 21:16:08 ramereth Exp $
+
+*ganeti-htools-0.2.5 (07 May 2010)
+
+ 07 May 2010; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-htools-0.2.5.ebuild:
+ version bump
*ganeti-htools-0.2.4 (11 Mar 2010)
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.2.5.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.2.5.ebuild
new file mode 100644
index 000000000000..5d01e6673454
--- /dev/null
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.2.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.5.ebuild,v 1.1 2010/05/07 21:16:08 ramereth Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
+clusters."
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/ghc
+ dev-haskell/json
+ dev-haskell/curl
+ dev-haskell/network"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # htools does not currently compile cleanly with ghc-6.12+, so remove this
+ # for now
+ sed -i -e "s:-Werror ::" Makefile
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dosbin hspace hscan hbal
+ exeinto /usr/$(get_libdir)/ganeti/iallocators
+ doexe hail
+ doman *.1
+ dodoc README NEWS AUTHORS
+}