summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-09-16 22:21:35 +0000
committerHanno Böck <hanno@gentoo.org>2008-09-16 22:21:35 +0000
commit06e237ac5e51e6d9c156338f86a5d2f1e4a72863 (patch)
tree336abe0fd52982a82fb85dd6a94abf8b02a47dc1 /app-emulation
parentStable for HPPA (bug #234075). (diff)
downloadgentoo-2-06e237ac5e51e6d9c156338f86a5d2f1e4a72863.tar.gz
gentoo-2-06e237ac5e51e6d9c156338f86a5d2f1e4a72863.tar.bz2
gentoo-2-06e237ac5e51e6d9c156338f86a5d2f1e4a72863.zip
ies4linux bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 i686)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ies4linux/ChangeLog7
-rw-r--r--app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild6
-rw-r--r--app-emulation/ies4linux/ies4linux-2.99.0.1.ebuild120
3 files changed, 129 insertions, 4 deletions
diff --git a/app-emulation/ies4linux/ChangeLog b/app-emulation/ies4linux/ChangeLog
index 880d4922d3ac..1ebc788aa39e 100644
--- a/app-emulation/ies4linux/ChangeLog
+++ b/app-emulation/ies4linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/ies4linux
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ChangeLog,v 1.6 2008/08/23 18:11:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ChangeLog,v 1.7 2008/09/16 22:21:35 hanno Exp $
+
+*ies4linux-2.99.0.1 (16 Sep 2008)
+
+ 16 Sep 2008; Hanno Boeck <hanno@gentoo.org> +ies4linux-2.99.0.1.ebuild:
+ Version bump, thanks to Oldrich Jedlicka in #204889.
23 Aug 2008; Markus Meier <maekke@gentoo.org> ies4linux-2.0.5.ebuild:
add ~amd64, bug #218667
diff --git a/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild b/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild
index 43a28dd09cd9..accd528f9f1a 100644
--- a/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild
+++ b/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild,v 1.3 2007/08/17 21:09:11 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ies4linux-2.5_beta6.ebuild,v 1.4 2008/09/16 22:21:35 hanno Exp $
inherit eutils versionator
@@ -28,7 +28,7 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-Installation_directory_discovery.patch" || die "epatch failed"
diff --git a/app-emulation/ies4linux/ies4linux-2.99.0.1.ebuild b/app-emulation/ies4linux/ies4linux-2.99.0.1.ebuild
new file mode 100644
index 000000000000..6fb46a27f5c7
--- /dev/null
+++ b/app-emulation/ies4linux/ies4linux-2.99.0.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ies4linux/ies4linux-2.99.0.1.ebuild,v 1.1 2008/09/16 22:21:35 hanno Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="Installer for Microsoft Internet Explorer"
+HOMEPAGE="http://www.ies4linux.org/"
+SRC_URI="http://www.ies4linux.org/downloads/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk kde"
+
+DEPEND=">=app-arch/cabextract-1.0
+ >=app-emulation/wine-0.9.0"
+
+RDEPEND="${DEPEND}
+ gtk? ( dev-python/pygtk
+ >=dev-lang/python-2.4 )
+ kde? ( || ( kde-base/kommander kde-base/kdewebdev ) )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/ies4linux-2.5_beta6-Installation_directory_discovery.patch" || die
+}
+
+src_install() {
+
+ INS_BASE_PATH="/usr/lib/${PN}"
+
+ # Main executable script
+
+ insinto "${INS_BASE_PATH}"
+
+ insopts -m0755
+ doins "${PN}" || die "doins failed"
+
+ dosym "${INS_BASE_PATH}/${PN}" "/usr/bin/${PN}" || die "dosym failed"
+
+ # Main libraries
+
+ insinto "${INS_BASE_PATH}/lib"
+
+ insopts -m0644
+ ( doins "lib/files" &&
+ doins "lib/${PN}.svg" &&
+ doins "lib/${PN}.png" &&
+ doins "lib/messages.txt"
+ ) || die "doins failed"
+
+ insopts -m0755
+ ( doins "lib/"*.sh &&
+ doins "lib/xdg-desktop-icon" &&
+ doins "lib/xdg-desktop-menu"
+ ) || die "doins failed"
+
+ # Localization libraries
+
+ insinto "${INS_BASE_PATH}/lang"
+
+ insopts -m0644
+ doins "lang/"*.sh || die "doins failed"
+
+ # Windows registry files
+
+ insinto "${INS_BASE_PATH}/winereg"
+
+ insopts -m0644
+ doins "winereg/"*.reg || die "doins failed"
+
+ # Graphical installers
+
+ insopts -m0644
+
+ insinto "${INS_BASE_PATH}/ui/kommander"
+ ( doins "ui/kommander/"*.kmdr &&
+ doins "ui/kommander/"*.sh
+ ) || die "doins failed"
+
+ insinto "${INS_BASE_PATH}/ui/pygtk"
+ ( doins "ui/pygtk/"*.py &&
+ doins "ui/pygtk/"*.sh
+ ) || die "doins failed"
+
+ # Documentation
+
+ dodoc "README" || die "dodoc failed"
+}
+
+pkg_postinst() {
+
+ elog
+ elog "IEs4Linux is an installer for Microsoft Internet Explorer."
+ elog "You just emerged the installer, you now have to run \`${PN}\`,"
+ elog "as a normal user, to actually install Microsoft Internet Explorer."
+ elog
+
+ use gtk && (
+ elog "To use the PyGTK installer interface, start IEs4Linux"
+ elog "with the \"--gui gtk\" option."
+ elog
+ )
+
+ use kde && (
+ elog "To use the KDE Kommander installer interface, start IEs4Linux"
+ elog "with the \"--gui kommander\" option."
+ elog
+ )
+
+ elog "Do note that, while IEs4Linux itself, is licensed under the GPL-2,"
+ elog "it is only an installer for Microsoft Internet Explorer. You must own"
+ elog "a Microsoft Windows license, and agree to the Internet Explorer license,"
+ elog "to install any version of Microsoft Internet Explorer."
+ elog
+}