summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2012-11-07 14:17:25 +0000
committerLuca Barbato <lu_zero@gentoo.org>2012-11-07 14:17:25 +0000
commit11a21966b71e2771529907d5908e84b47597243e (patch)
tree3ec06e88b3d95a888e14f28f68086788e13e3c1d /app-emulation
parentbump (diff)
downloadgentoo-2-11a21966b71e2771529907d5908e84b47597243e.tar.gz
gentoo-2-11a21966b71e2771529907d5908e84b47597243e.tar.bz2
gentoo-2-11a21966b71e2771529907d5908e84b47597243e.zip
New ebuild provided by Hendrik v. Raven<hendrik@consetetur.de> in bug #399645
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 1191738E)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog9
-rw-r--r--app-emulation/bochs/bochs-2.6.ebuild87
-rw-r--r--app-emulation/bochs/metadata.xml4
3 files changed, 98 insertions, 2 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 896ca8bf1183..5e368e4abbf1 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/bochs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.89 2011/09/15 07:39:28 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.90 2012/11/07 14:17:25 lu_zero Exp $
+
+*bochs-2.6 (07 Nov 2012)
+
+ 07 Nov 2012; Luca Barbato <lu_zero@gentoo.org> +bochs-2.6.ebuild:
+ New ebuild provided by Hendrik v. Raven<hendrik@consetetur.de> in bug #399645
15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> -bochs-2.3.ebuild,
-bochs-2.3.6.ebuild, -bochs-2.3.7.ebuild, -files/bochs-2.3.7-gcc43.patch,
diff --git a/app-emulation/bochs/bochs-2.6.ebuild b/app-emulation/bochs/bochs-2.6.ebuild
new file mode 100644
index 000000000000..31471af72ed9
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.6.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.6.ebuild,v 1.1 2012/11/07 14:17:25 lu_zero Exp $
+
+EAPI=4
+
+WX_GTK_VER=2.8
+
+inherit eutils wxwidgets
+
+DESCRIPTION="LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp wxwidgets vnc X +x86-64"
+REQUIRED_USE="avx? ( x86-64 )
+ gdb? ( !debugger !smp )
+ debugger? ( !gdb )"
+
+RDEPEND="X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )
+ readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )
+ X? ( x11-proto/xproto )
+ sys-apps/sed
+ >=app-text/opensp-1.5"
+
+src_prepare() {
+ sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
+ Makefile.in || die
+}
+
+src_configure() {
+ use wxwidgets && \
+ need-wxwidgets unicode
+
+ econf \
+ --enable-all-optimizations \
+ --enable-idle-hack \
+ --enable-cdrom \
+ --enable-clgd54xx \
+ --enable-cpu-level=6 \
+ --enable-disasm \
+ --enable-e1000 \
+ --enable-gameport \
+ --enable-iodebug \
+ --enable-monitor-mwait \
+ --enable-ne2000 \
+ --enable-plugins \
+ --enable-pci \
+ --enable-pcidev \
+ --enable-pnic \
+ --enable-raw-serial \
+ --enable-sb16=linux \
+ --enable-usb \
+ --enable-usb-ohci \
+ --enable-usb-xhci \
+ --prefix=/usr \
+ --with-nogui \
+ $(use_enable 3dnow) \
+ $(use_enable avx) \
+ $(use_enable debugger) \
+ $(use_enable doc docbook) \
+ $(use_enable gdb gdb-stub) \
+ $(use_enable readline) \
+ $(use_enable smp) \
+ $(use_enable x86-64) \
+ $(use_with ncurses term) \
+ $(use_with sdl) \
+ $(use_with svga) \
+ $(use_with vnc rfb) \
+ $(use_with wxwidgets wx) \
+ $(use_with X x) \
+ $(use_with X x11) \
+ ${myconf}
+}
diff --git a/app-emulation/bochs/metadata.xml b/app-emulation/bochs/metadata.xml
index 03a27eca1430..0c208d93633b 100644
--- a/app-emulation/bochs/metadata.xml
+++ b/app-emulation/bochs/metadata.xml
@@ -6,5 +6,9 @@
</maintainer>
<use>
<flag name='debugger'>Enable the bochs debugger</flag>
+ <flag name="avx">Enable support for Advanced Vector Extensions (AVX)</flag>
+ <flag name="debugger">Enable debugger (slows down emulation)</flag>
+ <flag name="gdb">Enable support for the remote GDB stub</flag>
+ <flag name="x86-64">Enable support for emulation of 64-bit CPUs</flag>
</use>
</pkgmetadata>