summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-09-15 18:02:23 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-09-15 18:02:23 +0000
commit41b96fafaed1a58ffccd91b1216eb35fd883c54f (patch)
tree2405602100788349a23fb8e803a15ee8b39471ef /app-emulation
parentx86 stable, security bug 383107 (diff)
downloadgentoo-2-41b96fafaed1a58ffccd91b1216eb35fd883c54f.tar.gz
gentoo-2-41b96fafaed1a58ffccd91b1216eb35fd883c54f.tar.bz2
gentoo-2-41b96fafaed1a58ffccd91b1216eb35fd883c54f.zip
Fix bug #382673
(Portage version: 2.1.10.16/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/aqemu/ChangeLog6
-rw-r--r--app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch82
2 files changed, 44 insertions, 44 deletions
diff --git a/app-emulation/aqemu/ChangeLog b/app-emulation/aqemu/ChangeLog
index 539bb4f3f269..0772cb5def3b 100644
--- a/app-emulation/aqemu/ChangeLog
+++ b/app-emulation/aqemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/aqemu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aqemu/ChangeLog,v 1.7 2011/09/11 16:58:52 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aqemu/ChangeLog,v 1.8 2011/09/15 18:02:23 maksbotan Exp $
+
+ 15 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org>
+ files/aqemu-0.8.2_sigsev_propertis.patch:
+ Resolve #382673; thanks Kent Hagebrand for patch fix
11 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org> aqemu-0.8.2-r1.ebuild:
Fix repoman leading space errors
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch b/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch
index 6fa33a3c5e9b..b7cc5950bd5f 100644
--- a/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch
+++ b/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch
@@ -1,45 +1,41 @@
-X-Git-Url: http://aqemu.git.sourceforge.net/git/gitweb.cgi?p=aqemu%2Faqemu;a=blobdiff_plain;f=Device_Manager_Widget.cpp;h=671930a152de6bf98b9218df7cb9cb1ca29e570d;hp=7288bafc6887841b94dd846a9df523205aa72a22;hb=18
-
-diff --git a/Device_Manager_Widget.cpp b/Device_Manager_Widget.cpp
-index 7288baf..671930a 100644
---- a/Device_Manager_Widget.cpp
-+++ b/Device_Manager_Widget.cpp
-@@ -981,9 +981,10 @@ void Device_Manager_Widget::on_actionDelete_triggered()
- {
- if( ui.Devices_List->currentItem()->data(512).toString() == "device" + QString::number(fx) )
- {
-- finded = true;
--
- Storage_Devices.removeAt( fx );
-+ ui.Devices_List->takeItem( ui.Devices_List->currentRow() );
-+ finded = true;
-+ break;
- }
- }
-
-@@ -993,10 +994,24 @@ void Device_Manager_Widget::on_actionDelete_triggered()
- "Incorrect Device!" );
- return;
- }
-+ else
-+ {
-+ // Rename items
-+ for( int ix = 0, count = 0; ix < ui.Devices_List->count(); ++ix )
-+ {
-+ if( ui.Devices_List->item(ix)->data(512).toString().contains("device") )
-+ {
-+ ui.Devices_List->item(ix)->setData( 512, QString("device%1").arg(count) );
-+ ++count;
-+ }
-+ }
-+
-+ emit Device_Changet();
-+ return;
-+ }
- }
-
- ui.Devices_List->takeItem( ui.Devices_List->currentRow() );
--
- emit Device_Changet();
+--- a/Device_Manager_Widget.cpp 2011-09-13 21:45:58.883389571 +0200
++++ b/Device_Manager_Widget.cpp 2011-09-13 21:55:01.401866022 +0200
+@@ -981,9 +981,10 @@
+ {
+ if( ui.Devices_List->currentItem()->data(512).toString() == "device" + QString::number(fx) )
+ {
+- finded = true;
+-
+ Storage_Devices.removeAt( fx );
++ ui.Devices_List->takeItem( ui.Devices_List->currentRow() );
++ finded = true;
++ break;
+ }
+ }
+
+@@ -993,10 +994,24 @@
+ "Incorrect Device!" );
+ return;
+ }
++ else
++ {
++ // Rename items
++ for( int ix = 0, count = 0; ix < ui.Devices_List->count(); ++ix )
++ {
++ if( ui.Devices_List->item(ix)->data(512).toString().contains("device") )
++ {
++ ui.Devices_List->item(ix)->setData( 512, QString("device%1").arg(count) );
++ ++count;
++ }
++ }
++
++ emit Device_Changet();
++ return;
++ }
+ }
+
+ ui.Devices_List->takeItem( ui.Devices_List->currentRow() );
+-
+ emit Device_Changet();
}