summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-04-06 16:01:13 +0000
committerTilman Klar <phoenix@gentoo.org>2003-04-06 16:01:13 +0000
commit4e6e12c8d0a799124982e27aa3dbe0d7dd7703ea (patch)
treec0ccc8f79e17421a7daa874b1e422925eb977e4c /app-emulation
parentBugfix & Version bumped. (diff)
downloadgentoo-2-4e6e12c8d0a799124982e27aa3dbe0d7dd7703ea.tar.gz
gentoo-2-4e6e12c8d0a799124982e27aa3dbe0d7dd7703ea.tar.bz2
gentoo-2-4e6e12c8d0a799124982e27aa3dbe0d7dd7703ea.zip
Forgot to add the dynamic content to cvs. :/
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog10
-rw-r--r--app-emulation/wine/files/digest-wine-200303181
-rw-r--r--app-emulation/wine/files/wine-20030318-fake_windows.tar.bz2bin0 -> 500 bytes
-rw-r--r--app-emulation/wine/files/wine-20030318-misc.tar.bz2bin0 -> 4591 bytes
-rw-r--r--app-emulation/wine/wine-20030318.ebuild118
5 files changed, 128 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index a8d8b4845f4f..e4d2d92144d3 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.31 2003/04/01 18:09:22 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.32 2003/04/06 16:01:13 phoenix Exp $
+
+*wine-20030318 (06 Apr 2003)
+
+ 06 Apr 2003; Tilman Klar <phoenix@gentoo.org> wine-20030318.ebuild,
+ files/digest-wine-20030318 :
+ Version bump.
+
+*wine-* (01 Apr 2003)
01 Apr 2003; phoen][x <phoenix@gentoo.org> *.ebuild :
Replaced 'export C{XX}FLAGS=""' with 'unset CFLAGS CXXFLAGS'.
diff --git a/app-emulation/wine/files/digest-wine-20030318 b/app-emulation/wine/files/digest-wine-20030318
new file mode 100644
index 000000000000..d7612c0f44a6
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20030318
@@ -0,0 +1 @@
+MD5 a4d1596fb27a9f1530c979250a4a48cd Wine-20030318.tar.gz 8378240
diff --git a/app-emulation/wine/files/wine-20030318-fake_windows.tar.bz2 b/app-emulation/wine/files/wine-20030318-fake_windows.tar.bz2
new file mode 100644
index 000000000000..d60f11e08ee3
--- /dev/null
+++ b/app-emulation/wine/files/wine-20030318-fake_windows.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/files/wine-20030318-misc.tar.bz2 b/app-emulation/wine/files/wine-20030318-misc.tar.bz2
new file mode 100644
index 000000000000..90b963f8896c
--- /dev/null
+++ b/app-emulation/wine/files/wine-20030318-misc.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/wine-20030318.ebuild b/app-emulation/wine/wine-20030318.ebuild
new file mode 100644
index 000000000000..00c646ae7539
--- /dev/null
+++ b/app-emulation/wine/wine-20030318.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030318.ebuild,v 1.1 2003/04/06 16:01:13 phoenix Exp $
+
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl
+ dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # use the default setting in ./configure over the /etc/make.conf setting
+ unset CFLAGS CXXFLAGS
+
+ ./configure --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${FILESDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${FILESDIR}/${P}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+ einfo "If you have further questions, enhancements or patches"
+ einfo "send an email to phoenix@gentoo.org"
+}