summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-06-08 01:11:20 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-06-08 01:11:20 +0000
commit62dbf876fe8b5b6d9b4fb6d98925ee4a80ad9c2d (patch)
treea6238c107b23ae9dc6b597f2b14a2f0d6fdce4da /app-emulation
parentVersion bump. Fix security bug 543858. (diff)
downloadgentoo-2-62dbf876fe8b5b6d9b4fb6d98925ee4a80ad9c2d.tar.gz
gentoo-2-62dbf876fe8b5b6d9b4fb6d98925ee4a80ad9c2d.tar.bz2
gentoo-2-62dbf876fe8b5b6d9b4fb6d98925ee4a80ad9c2d.zip
lets use a better cloud.cfg
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cloud-init/ChangeLog8
-rw-r--r--app-emulation/cloud-init/cloud-init-0.7.5-r3.ebuild88
-rw-r--r--app-emulation/cloud-init/files/cloud.cfg96
3 files changed, 191 insertions, 1 deletions
diff --git a/app-emulation/cloud-init/ChangeLog b/app-emulation/cloud-init/ChangeLog
index 7ac1c8864de2..22d45337e79d 100644
--- a/app-emulation/cloud-init/ChangeLog
+++ b/app-emulation/cloud-init/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/cloud-init
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/ChangeLog,v 1.14 2015/03/08 23:37:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/ChangeLog,v 1.15 2015/06/08 01:11:20 prometheanfire Exp $
+
+*cloud-init-0.7.5-r3 (08 Jun 2015)
+
+ 08 Jun 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +cloud-init-0.7.5-r3.ebuild, +files/cloud.cfg:
+ lets use a better cloud.cfg
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> cloud-init-0.7.6.ebuild:
x86 stable, bug 540290
diff --git a/app-emulation/cloud-init/cloud-init-0.7.5-r3.ebuild b/app-emulation/cloud-init/cloud-init-0.7.5-r3.ebuild
new file mode 100644
index 000000000000..737db0bf0487
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-0.7.5-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/cloud-init-0.7.5-r3.ebuild,v 1.1 2015/06/08 01:11:20 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=TRUE
+
+inherit distutils-r1 eutils multilib systemd
+
+DESCRIPTION="Cloud instance initialization"
+HOMEPAGE="http://launchpad.net/cloud-init"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/oauth[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
+ dev-python/mocker[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ sys-apps/iproute2
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ virtual/logger
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}-tests-exclude.patch
+ )
+
+ distutils-r1_python_prepare_all
+
+ # Skip SmartOS tests since they don't generally apply and don't skip based
+ # on environment. Documented in bug #511384.
+ rm tests/unittests/test_datasource/test_smartos.py
+}
+
+python_test() {
+ # These tests are not broken but expect to locate an installed exe file
+ # other than where a gentoo system installs it; (/bin/ip sought in /sbin)
+ # See cloudinit/sources/DataSourceOpenNebula.py for possible patching
+ sed \
+ -e 's:test_hostname:_&:' \
+ -e 's:test_network_interfaces:_&:' \
+ -i tests/unittests/test_datasource/test_opennebula.py
+
+ emake test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doinitd "${S}"/sysvinit/gentoo/cloud-config
+ doinitd "${S}"/sysvinit/gentoo/cloud-final
+ doinitd "${S}"/sysvinit/gentoo/cloud-init
+ doinitd "${S}"/sysvinit/gentoo/cloud-init-local
+
+ systemd_dounit "${S}"/systemd/cloud-config.service
+ systemd_dounit "${S}"/systemd/cloud-config.target
+ systemd_dounit "${S}"/systemd/cloud-final.service
+ systemd_dounit "${S}"/systemd/cloud-init-local.service
+ systemd_dounit "${S}"/systemd/cloud-init.service
+
+ rm /etc/cloud/cloud.cfg
+ insinto /etc/cloud
+ doins "${FILESDIR}/cloud.cfg"
+}
diff --git a/app-emulation/cloud-init/files/cloud.cfg b/app-emulation/cloud-init/files/cloud.cfg
new file mode 100644
index 000000000000..f20ab5a1544f
--- /dev/null
+++ b/app-emulation/cloud-init/files/cloud.cfg
@@ -0,0 +1,96 @@
+# The top level settings are used as module
+# and system configuration.
+
+# A set of users which may be applied and/or used by various modules
+# when a 'default' entry is found it will reference the 'default_user'
+# from the distro configuration specified below
+users:
+ - default
+
+# If this is set, 'root' will not be able to ssh in and they
+# will get a message to login instead as the above $user (ubuntu)
+disable_root: true
+
+# This will cause the set+update hostname module to not operate (if true)
+preserve_hostname: false
+
+# Example datasource config
+# datasource:
+# Ec2:
+# metadata_urls: [ 'blah.com' ]
+# timeout: 5 # (defaults to 50 seconds)
+# max_wait: 10 # (defaults to 120 seconds)
+
+# The modules that run in the 'init' stage
+cloud_init_modules:
+ - migrator
+ - ubuntu-init-switch
+ - seed_random
+ - bootcmd
+ - write-files
+ - growpart
+ - resizefs
+ - set_hostname
+ - update_hostname
+ - update_etc_hosts
+ - ca-certs
+ - rsyslog
+ - users-groups
+ - ssh
+
+# The modules that run in the 'config' stage
+cloud_config_modules:
+# Emit the cloud config ready event
+# this can be used by upstart jobs for 'start on cloud-config'.
+ - emit_upstart
+ - disk_setup
+ - mounts
+ - ssh-import-id
+ - locale
+ - set-passwords
+ - grub-dpkg
+ - apt-pipelining
+ - apt-configure
+ - package-update-upgrade-install
+ - landscape
+ - timezone
+ - puppet
+ - chef
+ - salt-minion
+ - mcollective
+ - disable-ec2-metadata
+ - runcmd
+ - byobu
+
+# The modules that run in the 'final' stage
+cloud_final_modules:
+ - rightscale_userdata
+ - scripts-vendor
+ - scripts-per-once
+ - scripts-per-boot
+ - scripts-per-instance
+ - scripts-user
+ - ssh-authkey-fingerprints
+ - keys-to-console
+ - phone-home
+ - final-message
+ - power-state-change
+
+# System and/or distro specific settings
+# (not accessible to handlers/transforms)
+system_info:
+ # This will affect which distro class gets used
+ distro: gentoo
+ # Default user name + that default users groups (if added/used)
+ default_user:
+ name: gentoo
+ lock_passwd: True
+ gecos: gentoo
+ groups: [adm]
+ sudo: ["ALL=(ALL) NOPASSWD:ALL"]
+ shell: /bin/bash
+ # Other config here will be given to the distro class and/or path classes
+ paths:
+ cloud_dir: /var/lib/cloud/
+ templates_dir: /etc/cloud/templates/
+ ssh_svcname: sshd