summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-19 20:52:26 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-19 20:52:26 +0000
commit6a7e06dd3108996be37e93733e5162915a8b91dc (patch)
tree8492bc1661ad3484f1aef480e646b93c1d6ffeec /app-emulation
parentUpdate version. Make it easier to choose between internal and external (diff)
downloadgentoo-2-6a7e06dd3108996be37e93733e5162915a8b91dc.tar.gz
gentoo-2-6a7e06dd3108996be37e93733e5162915a8b91dc.tar.bz2
gentoo-2-6a7e06dd3108996be37e93733e5162915a8b91dc.zip
ver bump
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winex-transgaming/ChangeLog10
-rw-r--r--app-emulation/winex-transgaming/files/digest-winex-transgaming-3.21
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-3.2.ebuild54
3 files changed, 63 insertions, 2 deletions
diff --git a/app-emulation/winex-transgaming/ChangeLog b/app-emulation/winex-transgaming/ChangeLog
index 6e89b8cee238..1582ba8526c7 100644
--- a/app-emulation/winex-transgaming/ChangeLog
+++ b/app-emulation/winex-transgaming/ChangeLog
@@ -1,12 +1,18 @@
# ChangeLog for app-emulation/winex-transgaming
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.7 2003/09/09 07:12:55 sergey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.8 2003/11/19 20:52:26 vapier Exp $
+
+*winex-transgaming-3.2 (19 Nov 2003)
+
+ 19 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ New release #33799.
+
+*winex-transgaming-3.1 (18 Jun 2003)
09 Sep 2003; Sergey Kuleshov <svyatogor@gentoo.org>
winex-transgaming-3.1.ebuild:
Bumping 3.1 to stable.
-*winex-transgaming-3.1 (18 Jun 2003)
18 Jun 2003; Thomas Raschbacher <lordvan@gentoo.org> winex-transgaming-3.1.ebuild:
new version
diff --git a/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.2 b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.2
new file mode 100644
index 000000000000..4dcdd764d61f
--- /dev/null
+++ b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.2
@@ -0,0 +1 @@
+MD5 eed79c857c1408fe332f872f71dc1426 winex3_3.2-1.i386.tgz 6890202
diff --git a/app-emulation/winex-transgaming/winex-transgaming-3.2.ebuild b/app-emulation/winex-transgaming/winex-transgaming-3.2.ebuild
new file mode 100644
index 000000000000..f93a0e1b5107
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-3.2.ebuild,v 1.1 2003/11/19 20:52:26 vapier Exp $
+
+MY_P="winex3_${PV}-1.i386"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate WineX archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo ""
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install () {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/winex3 to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+}