summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-04-20 19:01:08 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-04-20 19:01:08 +0000
commit757b4835bd930510c54b54ec759b5bf462694684 (patch)
treef2c9dcf383ef6ce27e86fd93736455ad35484f37 /app-emulation
parentInstall fsck binaries into /sbin #218540. (diff)
downloadgentoo-2-757b4835bd930510c54b54ec759b5bf462694684.tar.gz
gentoo-2-757b4835bd930510c54b54ec759b5bf462694684.tar.bz2
gentoo-2-757b4835bd930510c54b54ec759b5bf462694684.zip
Move the gcc check in src_unpack
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog6
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild16
2 files changed, 12 insertions, 10 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 039cd1f2c755..eb4f54f6f74b 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.48 2008/03/09 15:11:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.49 2008/04/20 19:01:08 lu_zero Exp $
+
+ 20 Apr 2008; Luca Barbato <lu_zero@gentoo.org>
+ qemu-softmmu-0.9.1-r1.ebuild:
+ Move the gcc check in src_unpack
09 Mar 2008; Luca Barbato <lu_zero@gentoo.org>
qemu-softmmu-0.9.1-r1.ebuild:
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild
index 5d31c4ec0bb7..6167e858cc74 100644
--- a/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild,v 1.2 2008/03/09 15:11:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.9.1-r1.ebuild,v 1.3 2008/04/20 19:01:08 lu_zero Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -31,17 +31,15 @@ RDEPEND="sys-libs/zlib
S="${WORKDIR}/${P/-softmmu/}"
-pkg_setup() {
+src_unpack() {
if [ "$(gcc-major-version)" == "4" ]; then
- eerror "qemu requires gcc-3 in order to build and work correctly"
- eerror "please compile it switching to gcc-3."
- eerror "We are aware that qemu can guess a gcc-3 but this feature"
- eerror "could be harmful."
- die "gcc 4 cannot build qemu"
+ eerror "qemu requires gcc-3 in order to build and work correctly"
+ eerror "please compile it switching to gcc-3."
+ eerror "We are aware that qemu can guess a gcc-3 but this feature"
+ eerror "could be harmful."
+ die "gcc 4 cannot build qemu"
fi
-}
-src_unpack() {
unpack ${A}
cd "${S}"