summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2015-07-28 13:57:07 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2015-07-28 13:57:07 +0000
commit996ad4162914ffd2e85a5ab788a9f89c865a0eed (patch)
tree9264e905b0cb26ec1828c00a1659acd22695647b /app-emulation
parentVersion bump. Removed old (diff)
downloadgentoo-2-996ad4162914ffd2e85a5ab788a9f89c865a0eed.tar.gz
gentoo-2-996ad4162914ffd2e85a5ab788a9f89c865a0eed.tar.bz2
gentoo-2-996ad4162914ffd2e85a5ab788a9f89c865a0eed.zip
Make kernel chchecks non fatal. Thanks to Tianon <admwiggin@gmail.com> for the patch. Fixes #555434 by Deniss Gaplevsky <slim@inbox.lv>
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker/ChangeLog6
-rw-r--r--app-emulation/docker/docker-1.7.1.ebuild25
2 files changed, 17 insertions, 14 deletions
diff --git a/app-emulation/docker/ChangeLog b/app-emulation/docker/ChangeLog
index 2d504d48d3a6..534c6e3de3a5 100644
--- a/app-emulation/docker/ChangeLog
+++ b/app-emulation/docker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/docker
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/ChangeLog,v 1.55 2015/07/24 18:48:39 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/ChangeLog,v 1.56 2015/07/28 13:57:07 xarthisius Exp $
+
+ 28 Jul 2015; Kacper Kowalik <xarthisius@gentoo.org> docker-1.7.1.ebuild:
+ Make kernel chchecks non fatal. Thanks to Tianon <admwiggin@gmail.com> for the
+ patch. Fixes #555434 by Deniss Gaplevsky <slim@inbox.lv>
*docker-1.7.1 (24 Jul 2015)
diff --git a/app-emulation/docker/docker-1.7.1.ebuild b/app-emulation/docker/docker-1.7.1.ebuild
index 6c245c0e59af..591adb52a81f 100644
--- a/app-emulation/docker/docker-1.7.1.ebuild
+++ b/app-emulation/docker/docker-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/docker-1.7.1.ebuild,v 1.1 2015/07/24 18:48:39 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/docker-1.7.1.ebuild,v 1.2 2015/07/28 13:57:07 xarthisius Exp $
EAPI=5
@@ -76,15 +76,15 @@ RESTRICT="installsources strip"
# see "contrib/check-config.sh" from upstream's sources
CONFIG_CHECK="
- NAMESPACES NET_NS PID_NS IPC_NS UTS_NS
- DEVPTS_MULTIPLE_INSTANCES
- CGROUPS CGROUP_CPUACCT CGROUP_DEVICE CGROUP_FREEZER CGROUP_SCHED CPUSETS
- MACVLAN VETH BRIDGE BRIDGE_NETFILTER
- NF_NAT_IPV4 IP_NF_FILTER IP_NF_TARGET_MASQUERADE
- NETFILTER_XT_MATCH_ADDRTYPE NETFILTER_XT_MATCH_CONNTRACK
- NF_NAT NF_NAT_NEEDED
+ ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS UTS_NS
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS
+ ~MACVLAN ~VETH ~BRIDGE ~BRIDGE_NETFILTER
+ ~NF_NAT_IPV4 ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
+ ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK
+ ~NF_NAT ~NF_NAT_NEEDED
- POSIX_MQUEUE
+ ~POSIX_MQUEUE
~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
@@ -101,10 +101,9 @@ ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics
pkg_setup() {
if kernel_is lt 3 10; then
- eerror ""
- eerror "Using Docker with kernels older than 3.10 is unstable and unsupported."
- eerror " - http://docs.docker.com/installation/binaries/#check-kernel-dependencies"
- die 'Kernel is too old - need 3.10 or above'
+ ewarn ""
+ ewarn "Using Docker with kernels older than 3.10 is unstable and unsupported."
+ ewarn " - http://docs.docker.com/installation/binaries/#check-kernel-dependencies"
fi
# for where these kernel versions come from, see: