summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-07 22:59:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-07 22:59:51 +0000
commitb589d402eec921e03cc4ab47e6d44ce6ed46ef0a (patch)
treefc82d00fecc17d654db3ff55e3ca55f6b0bc1974 /app-emulation
parent~alpha keyword. (diff)
downloadgentoo-2-b589d402eec921e03cc4ab47e6d44ce6ed46ef0a.tar.gz
gentoo-2-b589d402eec921e03cc4ab47e6d44ce6ed46ef0a.tar.bz2
gentoo-2-b589d402eec921e03cc4ab47e6d44ce6ed46ef0a.zip
export ABI for x86 on amd64
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-20050211.ebuild18
-rw-r--r--app-emulation/wine/wine-20050310.ebuild18
2 files changed, 22 insertions, 14 deletions
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index b243b8669052..2c69f2a9b4a1 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.8 2005/03/29 01:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.9 2005/04/07 22:59:51 vapier Exp $
inherit eutils flag-o-matic
@@ -39,12 +39,16 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ else
+ export ABI=x86
+ fi
fi
}
diff --git a/app-emulation/wine/wine-20050310.ebuild b/app-emulation/wine/wine-20050310.ebuild
index b4c6b3efc207..aa2711f54cfc 100644
--- a/app-emulation/wine/wine-20050310.ebuild
+++ b/app-emulation/wine/wine-20050310.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.6 2005/03/29 01:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.7 2005/04/07 22:59:51 vapier Exp $
inherit eutils flag-o-matic
@@ -39,12 +39,16 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ else
+ export ABI=x86
+ fi
fi
}