summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-10-27 16:57:55 +0000
committerLance Albertson <ramereth@gentoo.org>2011-10-27 16:57:55 +0000
commitf862a2e018724c908949c4a55773d768f0a81bb7 (patch)
tree7980e87f7e6172d1eaf3159c441164dd5c92fbc0 /app-emulation
parentFix libnl dependency. (diff)
downloadgentoo-2-f862a2e018724c908949c4a55773d768f0a81bb7.tar.gz
gentoo-2-f862a2e018724c908949c4a55773d768f0a81bb7.tar.bz2
gentoo-2-f862a2e018724c908949c4a55773d768f0a81bb7.zip
version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ChangeLog8
-rw-r--r--app-emulation/ganeti/ganeti-2.4.5.ebuild (renamed from app-emulation/ganeti/ganeti-2.4.2.ebuild)19
2 files changed, 17 insertions, 10 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 7e45e54c0627..c7d68ba5bcdb 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.55 2011/10/04 15:52:30 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.56 2011/10/27 16:57:55 ramereth Exp $
+
+*ganeti-2.4.5 (27 Oct 2011)
+
+ 27 Oct 2011; Lance Albertson <ramereth@gentoo.org> -ganeti-2.4.2.ebuild,
+ +ganeti-2.4.5.ebuild:
+ Version bump
*ganeti-2.5.0_rc1 (04 Oct 2011)
diff --git a/app-emulation/ganeti/ganeti-2.4.2.ebuild b/app-emulation/ganeti/ganeti-2.4.5.ebuild
index da6444646b42..01a4aa18f03f 100644
--- a/app-emulation/ganeti/ganeti-2.4.2.ebuild
+++ b/app-emulation/ganeti/ganeti-2.4.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.2.ebuild,v 1.2 2011/08/15 16:06:44 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.4.5.ebuild,v 1.1 2011/10/27 16:57:55 ramereth Exp $
EAPI=2
-inherit eutils confutils bash-completion
+inherit eutils confutils bash-completion-r1
MY_PV="${PV/_rc/~rc}"
#MY_PV="${PV/_beta/~beta}"
@@ -15,7 +15,7 @@ SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="kvm xen drbd +filestorage syslog ipv6"
S="${WORKDIR}/${MY_P}"
@@ -37,7 +37,8 @@ DEPEND="xen? ( >=app-emulation/xen-3.0 )
net-misc/openssh
net-misc/socat
sys-apps/iproute2
- sys-fs/lvm2"
+ sys-fs/lvm2
+ >=sys-apps/baselayout-2.0"
RDEPEND="${DEPEND}
!<app-emulation/ganeti-htools-0.3"
@@ -45,6 +46,10 @@ pkg_setup () {
confutils_require_any kvm xen
}
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-fix-start-stop.patch"
+}
+
src_configure () {
local myconf
if use filestorage ; then
@@ -67,7 +72,7 @@ src_install () {
newconfd "${FILESDIR}"/ganeti.confd ganeti
use kvm && newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
use kvm && newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
- dobashcompletion doc/examples/bash_completion ganeti
+ newbashcomp doc/examples/bash_completion ganeti
dodoc INSTALL UPGRADE NEWS README doc/*.rst
rm -rf "${D}"/usr/share/doc/ganeti
docinto examples
@@ -80,7 +85,3 @@ src_install () {
keepdir /usr/share/ganeti/os/
keepdir /var/lib/ganeti-storage/{export,file}/
}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}