summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-07-06 11:13:40 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-07-06 11:13:40 +0000
commit550fb86625147d2aa3c9c3a750d11cf726d093eb (patch)
tree0eb63ffae5e738c023291584b703a41120afe868 /app-forensics/lynis/lynis-1.5.6.ebuild
parentsci-biology/abyss: Add missing dep on boost, #515156 (diff)
downloadgentoo-2-550fb86625147d2aa3c9c3a750d11cf726d093eb.tar.gz
gentoo-2-550fb86625147d2aa3c9c3a750d11cf726d093eb.tar.bz2
gentoo-2-550fb86625147d2aa3c9c3a750d11cf726d093eb.zip
Version bump. Also fixes wrong doc permissions, bug 515626
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'app-forensics/lynis/lynis-1.5.6.ebuild')
-rw-r--r--app-forensics/lynis/lynis-1.5.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-forensics/lynis/lynis-1.5.6.ebuild b/app-forensics/lynis/lynis-1.5.6.ebuild
new file mode 100644
index 000000000000..863fbd7420b2
--- /dev/null
+++ b/app-forensics/lynis/lynis-1.5.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/lynis/lynis-1.5.6.ebuild,v 1.1 2014/07/06 11:13:40 idl0r Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="http://cisofy.com/lynis/"
+SRC_URI="http://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+src_prepare() {
+ # Bug 507438
+ epatch_user
+}
+
+src_install() {
+ doman lynis.8
+ dodoc CHANGELOG FAQ README dev/TODO
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0750
+ insopts -m0640
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}