summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-25 10:02:55 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-25 10:02:55 +0000
commit1ffcb5feeaad9b9f9a61ee3a24fe05d0ddf85791 (patch)
tree3dd8f5d276d984a55ed556389f0a5b364a886a43 /app-forensics/sleuthkit
parentadd IBPP license, version 1.1 (diff)
downloadgentoo-2-1ffcb5feeaad9b9f9a61ee3a24fe05d0ddf85791.tar.gz
gentoo-2-1ffcb5feeaad9b9f9a61ee3a24fe05d0ddf85791.tar.bz2
gentoo-2-1ffcb5feeaad9b9f9a61ee3a24fe05d0ddf85791.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-forensics/sleuthkit')
-rw-r--r--app-forensics/sleuthkit/ChangeLog7
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.0.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index 57a976d8689d..f98b21beb252 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.65 2012/10/23 09:15:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.66 2012/11/25 10:02:55 radhermit Exp $
+
+*sleuthkit-4.0.1 (25 Nov 2012)
+
+ 25 Nov 2012; Tim Harder <radhermit@gentoo.org> +sleuthkit-4.0.1.ebuild:
+ Version bump.
23 Oct 2012; Tim Harder <radhermit@gentoo.org> sleuthkit-3.2.3.ebuild:
Update libewf dep since the API-related use flag was changed in the most
diff --git a/app-forensics/sleuthkit/sleuthkit-4.0.1.ebuild b/app-forensics/sleuthkit/sleuthkit-4.0.1.ebuild
new file mode 100644
index 000000000000..a8f767d177c0
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-4.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-4.0.1.ebuild,v 1.1 2012/11/25 10:02:55 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="aff ewf static-libs"
+
+DEPEND="dev-db/sqlite:3
+ ewf? ( app-forensics/libewf )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+DOCS=( NEWS.txt README.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.0.0-system-sqlite.patch
+ epatch "${FILESDIR}"/${PN}-3.2.3-tools-shared-libs.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with aff afflib) \
+ $(use_with ewf libewf) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}