summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-07-27 21:08:47 +0000
committerRick Farina <zerochaos@gentoo.org>2013-07-27 21:08:47 +0000
commit0e1ffdbdd58f9bcd592e556849b071c9da783479 (patch)
tree59309dccc42f44cf22a1739dc6a6220f8bbb8dc7 /app-forensics
parentremoving my libewf[bfio] mask from yesterday (diff)
downloadgentoo-2-0e1ffdbdd58f9bcd592e556849b071c9da783479.tar.gz
gentoo-2-0e1ffdbdd58f9bcd592e556849b071c9da783479.tar.bz2
gentoo-2-0e1ffdbdd58f9bcd592e556849b071c9da783479.zip
new optional dep on libbfio
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog8
-rw-r--r--app-forensics/libewf/libewf-20130416-r1.ebuild54
-rw-r--r--app-forensics/libewf/metadata.xml1
3 files changed, 62 insertions, 1 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index 7d0904f2709a..f675545ff94e 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.51 2013/07/27 08:16:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.52 2013/07/27 21:08:47 zerochaos Exp $
+
+*libewf-20130416-r1 (27 Jul 2013)
+
+ 27 Jul 2013; Rick Farina <zerochaos@gentoo.org> +libewf-20130416-r1.ebuild,
+ metadata.xml:
+ new optional dep on libbfio
27 Jul 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Removing unneeded useflag description from metadata.xml
diff --git a/app-forensics/libewf/libewf-20130416-r1.ebuild b/app-forensics/libewf/libewf-20130416-r1.ebuild
new file mode 100644
index 000000000000..04931fa1ff0f
--- /dev/null
+++ b/app-forensics/libewf/libewf-20130416-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20130416-r1.ebuild,v 1.1 2013/07/27 21:08:47 zerochaos Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://code.google.com/p/libewf/"
+SRC_URI="http://libewf.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="bfio debug ewf +fuse rawio +ssl static-libs +uuid unicode zlib"
+
+DEPEND="
+ sys-libs/zlib
+ bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
+ fuse? ( sys-fs/fuse )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable rawio low-level-functions)
+ $(use_enable unicode wide-character-type)
+ $(use_with zlib)
+ # autodetects bzip2 but does not use
+ --without-bzip2
+ $(use_with bfio libbfio)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}
diff --git a/app-forensics/libewf/metadata.xml b/app-forensics/libewf/metadata.xml
index f6cb036712cd..8c8acdb43b78 100644
--- a/app-forensics/libewf/metadata.xml
+++ b/app-forensics/libewf/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>forensics</herd>
<use>
+ <flag name="bfio">Enables libbfio for chaining file in file handling</flag>
<flag name="rawio">Enables raw IO handling</flag>
<flag name="ewf">Enables the v1 API</flag>
<flag name="fuse">Enable fuse support for ewfmount</flag>