summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-11 21:41:07 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-11 21:41:07 +0000
commit4a3c34311a277bd80a822f052b77a187af931da1 (patch)
tree403f2ab85d29d00602a24fc5cdc8a05134d384aa /app-forensics
parentwhitespace (diff)
downloadgentoo-2-4a3c34311a277bd80a822f052b77a187af931da1.tar.gz
gentoo-2-4a3c34311a277bd80a822f052b77a187af931da1.tar.bz2
gentoo-2-4a3c34311a277bd80a822f052b77a187af931da1.zip
Version bump. Add static-libs use flag.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/ChangeLog8
-rw-r--r--app-forensics/afflib/afflib-3.6.12.ebuild54
-rw-r--r--app-forensics/afflib/files/afflib-3.6.12-python-module.patch12
3 files changed, 73 insertions, 1 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index aa5a8218684b..7ca9bd8f863a 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.10 2011/07/10 15:44:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.11 2011/07/11 21:41:07 radhermit Exp $
+
+*afflib-3.6.12 (11 Jul 2011)
+
+ 11 Jul 2011; Tim Harder <radhermit@gentoo.org> +afflib-3.6.12.ebuild,
+ +files/afflib-3.6.12-python-module.patch:
+ Version bump. Add static-libs use flag.
10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> afflib-3.6.8.ebuild:
Stable on amd64 wrt bug #374321
diff --git a/app-forensics/afflib/afflib-3.6.12.ebuild b/app-forensics/afflib/afflib-3.6.12.ebuild
new file mode 100644
index 000000000000..50dcc023348b
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.6.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.6.12.ebuild,v 1.1 2011/07/11 21:41:07 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="fuse ncurses python qemu readline s3 static-libs threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-python-module.patch
+
+ sed -i -e "/FLAGS/s: -g::" configure.ac
+ sed -i -e "/-static/d" tools/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ econf \
+ $(use_enable fuse) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable static-libs static) \
+ $(use_enable threads threading)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/app-forensics/afflib/files/afflib-3.6.12-python-module.patch b/app-forensics/afflib/files/afflib-3.6.12-python-module.patch
new file mode 100644
index 000000000000..13ecfe0f8503
--- /dev/null
+++ b/app-forensics/afflib/files/afflib-3.6.12-python-module.patch
@@ -0,0 +1,12 @@
+--- afflib-3.6.12/pyaff/Makefile.am.orig
++++ afflib-3.6.12/pyaff/Makefile.am
+@@ -7,7 +7,7 @@
+ pyexec_LTLIBRARIES = pyaff.la
+
+ pyaff_la_SOURCES = pyaff.c
+-pyaff_la_LIBADD = ../lib/libafflib.la
++pyaff_la_LIBADD = @top_builddir@/lib/libafflib.la
+ pyaff_la_CPPFLAGS = $(PYTHON_CPPFLAGS)
+-pyaff_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
++pyaff_la_LDFLAGS = -module -avoid-version -shared $(PYTHON_LDFLAGS)
+ endif