summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-27 22:06:13 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-27 22:06:13 +0000
commitbc76e59f2d96db0ee50ec6143eea0d4825e97a19 (patch)
tree9f8b8588735970db6deb28fd950766a36c1b5c6d /app-forensics
parentMarking gnome2-wnck-0.160.0 ppc for bug 400291 (diff)
downloadgentoo-2-bc76e59f2d96db0ee50ec6143eea0d4825e97a19.tar.gz
gentoo-2-bc76e59f2d96db0ee50ec6143eea0d4825e97a19.tar.bz2
gentoo-2-bc76e59f2d96db0ee50ec6143eea0d4825e97a19.zip
Version bump. Use system sqlite library (bug #383129) and respect LDFLAGS (bug #336951).
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog12
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-3.2.3-system-sqlite.patch23
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-3.2.3-tools-shared-libs.patch55
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild37
4 files changed, 125 insertions, 2 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index 845efd06eee6..59c7608ad2b4 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-forensics/sleuthkit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.52 2011/12/10 22:15:38 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.53 2012/02/27 22:06:12 radhermit Exp $
+
+*sleuthkit-3.2.3 (27 Feb 2012)
+
+ 27 Feb 2012; Tim Harder <radhermit@gentoo.org> +sleuthkit-3.2.3.ebuild,
+ +files/sleuthkit-3.2.3-system-sqlite.patch,
+ +files/sleuthkit-3.2.3-tools-shared-libs.patch:
+ Version bump. Use system sqlite library (bug #383129) and respect LDFLAGS
+ (bug #336951).
10 Dec 2011; Tim Harder <radhermit@gentoo.org> sleuthkit-3.2.1.ebuild,
sleuthkit-3.2.2.ebuild:
diff --git a/app-forensics/sleuthkit/files/sleuthkit-3.2.3-system-sqlite.patch b/app-forensics/sleuthkit/files/sleuthkit-3.2.3-system-sqlite.patch
new file mode 100644
index 000000000000..95aa3f270e54
--- /dev/null
+++ b/app-forensics/sleuthkit/files/sleuthkit-3.2.3-system-sqlite.patch
@@ -0,0 +1,23 @@
+--- sleuthkit-3.2.3/tsk3/auto/auto_db.cpp
++++ sleuthkit-3.2.3/tsk3/auto/auto_db.cpp
+@@ -14,7 +14,7 @@
+ */
+
+ #include "tsk_auto_i.h"
+-#include "sqlite3.h"
++#include <sqlite3.h>
+ #include <string.h>
+
+ #define TSK_SCHEMA_VER 1
+--- sleuthkit-3.2.3/tsk3/auto/Makefile.am
++++ sleuthkit-3.2.3/tsk3/auto/Makefile.am
+@@ -3,7 +3,8 @@
+
+ noinst_LTLIBRARIES = libtskauto.la
+ # Note that the .h files are in the top-level Makefile
+-libtskauto_la_SOURCES = auto.cpp tsk_auto_i.h auto_db.cpp sqlite3.c sqlite3.h
++libtskauto_la_SOURCES = auto.cpp tsk_auto_i.h auto_db.cpp
++libtskauto_la_LIBADD = -lsqlite3
+
+ indent:
+ indent *.cpp *.h
diff --git a/app-forensics/sleuthkit/files/sleuthkit-3.2.3-tools-shared-libs.patch b/app-forensics/sleuthkit/files/sleuthkit-3.2.3-tools-shared-libs.patch
new file mode 100644
index 000000000000..749c67030046
--- /dev/null
+++ b/app-forensics/sleuthkit/files/sleuthkit-3.2.3-tools-shared-libs.patch
@@ -0,0 +1,55 @@
+--- sleuthkit-3.2.3/tools/autotools/Makefile.am
++++ sleuthkit-3.2.3/tools/autotools/Makefile.am
+@@ -1,6 +1,5 @@
+ AM_CPPFLAGS = -I../.. -I$(srcdir)/../.. -Wall
+ LDADD = ../../tsk3/libtsk3.la
+-LDFLAGS += -static
+ EXTRA_DIST = .indent.pro
+
+ bin_PROGRAMS = tsk_recover tsk_loaddb tsk_comparedir tsk_gettimes
+--- sleuthkit-3.2.3/tools/fstools/Makefile.am
++++ sleuthkit-3.2.3/tools/fstools/Makefile.am
+@@ -1,6 +1,5 @@
+ AM_CPPFLAGS = -I../.. -I$(srcdir)/../.. -Wall
+ LDADD = ../../tsk3/libtsk3.la
+-LDFLAGS += -static
+ EXTRA_DIST = .indent.pro fscheck.cpp
+
+ bin_PROGRAMS = blkcalc blkcat blkls blkstat ffind fls fsstat icat ifind ils \
+--- sleuthkit-3.2.3/tools/hashtools/Makefile.am
++++ sleuthkit-3.2.3/tools/hashtools/Makefile.am
+@@ -1,6 +1,5 @@
+ AM_CPPFLAGS = -I../.. -I$(srcdir)/../.. -Wall
+ LDADD = ../../tsk3/libtsk3.la
+-LDFLAGS += -static
+ EXTRA_DIST = .indent.pro md5.c sha1.c
+
+ bin_PROGRAMS = hfind
+--- sleuthkit-3.2.3/tools/imgtools/Makefile.am
++++ sleuthkit-3.2.3/tools/imgtools/Makefile.am
+@@ -1,6 +1,5 @@
+ AM_CPPFLAGS = -I../.. -I$(srcdir)/../.. -Wall
+ LDADD = ../../tsk3/libtsk3.la
+-LDFLAGS += -static
+ EXTRA_DIST = .indent.pro
+
+ bin_PROGRAMS = img_cat img_stat
+--- sleuthkit-3.2.3/tools/srchtools/Makefile.am
++++ sleuthkit-3.2.3/tools/srchtools/Makefile.am
+@@ -6,7 +6,6 @@
+
+ sigfind_SOURCES = sigfind.cpp
+ sigfind_LDADD = ../../tsk3/libtsk3.la
+-sigfind_LDFLAGS = -static
+
+ indent:
+ indent *.c *.cpp
+--- sleuthkit-3.2.3/tools/vstools/Makefile.am
++++ sleuthkit-3.2.3/tools/vstools/Makefile.am
+@@ -1,6 +1,5 @@
+ AM_CPPFLAGS = -I../.. -I$(srcdir)/../.. -Wall
+ LDADD = ../../tsk3/libtsk3.la
+-LDFLAGS += -static
+ EXTRA_DIST = .indent.pro
+
+ bin_PROGRAMS = mmls mmstat mmcat
diff --git a/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild b/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
new file mode 100644
index 000000000000..2797e2328225
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild,v 1.1 2012/02/27 22:06:12 radhermit Exp $
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-utils
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+SLOT=0
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="aff ewf static-libs"
+
+DEPEND="ewf? ( app-forensics/libewf[-ewf2] )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+DOCS=( NEWS.txt README.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-sqlite.patch
+ "${FILESDIR}"/${P}-tools-shared-libs.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with aff afflib)
+ $(use_with ewf libewf)
+ )
+ autotools-utils_src_configure
+}