summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-19 00:37:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-19 00:37:48 +0000
commitfe1b110c72fdd120ce52c73b4199dfb2525f72ed (patch)
tree4b829116b802855642ddd101806723a909cbc9e3 /app-forensics
parentDisable building of the spec PDF, as that will cause sandbox violations, and ... (diff)
downloadgentoo-2-fe1b110c72fdd120ce52c73b4199dfb2525f72ed.tar.gz
gentoo-2-fe1b110c72fdd120ce52c73b4199dfb2525f72ed.tar.bz2
gentoo-2-fe1b110c72fdd120ce52c73b4199dfb2525f72ed.zip
Initial import of zzuf. Thanks also to Jakub Moc in bug #188646.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/zzuf/ChangeLog10
-rw-r--r--app-forensics/zzuf/Manifest4
-rw-r--r--app-forensics/zzuf/metadata.xml8
-rw-r--r--app-forensics/zzuf/zzuf-0.10.ebuild44
4 files changed, 66 insertions, 0 deletions
diff --git a/app-forensics/zzuf/ChangeLog b/app-forensics/zzuf/ChangeLog
new file mode 100644
index 000000000000..fc2f862e409f
--- /dev/null
+++ b/app-forensics/zzuf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-forensics/zzuf
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.1 2008/04/19 00:37:48 flameeyes Exp $
+
+*zzuf-0.10 (19 Apr 2008)
+
+ 19 Apr 2008; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ +zzuf-0.10.ebuild:
+ Initial import of zzuf. Thanks also to Jakub Moc in bug #188646.
+
diff --git a/app-forensics/zzuf/Manifest b/app-forensics/zzuf/Manifest
new file mode 100644
index 000000000000..fd36df99d028
--- /dev/null
+++ b/app-forensics/zzuf/Manifest
@@ -0,0 +1,4 @@
+DIST zzuf-0.10.tar.gz 425897 RMD160 521369e990b1e79db71de688494b264995baa508 SHA1 92d0948e6b821945011f9707244db6d17a4d0ba0 SHA256 a5fa82e49c01721f0ae339345780c55d1ae9e42ed6909901a1c688800e5b834c
+EBUILD zzuf-0.10.ebuild 1115 RMD160 31d60d7438e7779af270ed7c3c9cb7e0cf8d0043 SHA1 bf31133a80ed8dcbed89d89c6f93fec412f14e4e SHA256 f78a8b60dd3f6ebf6b6e212409bdafe3a7eda1d3533079afb2ad2c24d5a2b0ad
+MISC ChangeLog 302 RMD160 f8b8d4ccdccc9c1b662f697ca5855c40ac3d9597 SHA1 118c485915484551c88426f5831ffbb7dda22709 SHA256 40a294239b9a7d3813c911d6a6b6728ec72ca2c4affda8ea478e34c07fe4c1be
+MISC metadata.xml 225 RMD160 d973b4a3a0e8ed0a3bc126ecb9dea3ce3371371f SHA1 5872fd680b46d3aef07c0239f38a4362649f0de9 SHA256 0bc12d2711e9d0335e5a6b4561909de251122ba63cb2039e1f60e5cdcb52ad5b
diff --git a/app-forensics/zzuf/metadata.xml b/app-forensics/zzuf/metadata.xml
new file mode 100644
index 000000000000..d54bd3354d0d
--- /dev/null
+++ b/app-forensics/zzuf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>flameeyes@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-forensics/zzuf/zzuf-0.10.ebuild b/app-forensics/zzuf/zzuf-0.10.ebuild
new file mode 100644
index 000000000000..64021cbf538a
--- /dev/null
+++ b/app-forensics/zzuf/zzuf-0.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.10.ebuild,v 1.1 2008/04/19 00:37:48 flameeyes Exp $
+
+inherit autotools
+
+DESCRIPTION="Transparent application input fuzzer"
+HOMEPAGE="http://sam.zoy.org/zzuf/"
+SRC_URI="http://sam.zoy.org/zzuf/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e '/CFLAGS/d' "${S}/configure.ac" \
+ || die "unable to fix the configure.ac"
+ eautoreconf
+}
+
+src_compile() {
+ # Don't build the static library, as the library is only used for
+ # preloading, so there is no reason to build it statically, unless
+ # you want to use zzuf with a static-linked executable, which I'm
+ # not even sure would be a good idea.
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ find "${D}" -name '*.la' -delete
+}